kirkwood: move usb support to modules
authorPawel Dembicki <paweldembicki@gmail.com>
Thu, 30 Apr 2020 10:34:41 +0000 (12:34 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 14 Jun 2020 19:16:20 +0000 (21:16 +0200)
USB support built in kernel isn't required for booting.
This patch move USB support to modules.

CONFIG_USB_STORAGE is removed because it can be found in kmod-usb-storage
and all usb support for this targed is moved to kmods.

Tested-by: Cezary Jackiewicz <cezary@eko.one.pl> [nsa310]
Tested-by: Alberto Bursi <bobafetthotmail@gmail.com> [nsa325, ea4500]
Reviewed-by: Sungbo Eo <mans0n@gorani.run>
Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
[keep CONFIG_SCSI]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/generic/config-4.14
target/linux/generic/config-4.19
target/linux/generic/config-5.4
target/linux/kirkwood/Makefile
target/linux/kirkwood/config-5.4

index bcf47f10d1226edaa4817ad7fb961cc3ddd6a210..047921b3b1ec6ccd6b88e2d40f34505b994fb887 100644 (file)
@@ -5224,6 +5224,7 @@ CONFIG_USB_DEFAULT_PERSIST=y
 # CONFIG_USB_DYNAMIC_MINORS is not set
 # CONFIG_USB_EG20T is not set
 # CONFIG_USB_EHCI_ATH79 is not set
+# CONFIG_USB_EHCI_HCD is not set
 # CONFIG_USB_EHCI_HCD_AT91 is not set
 # CONFIG_USB_EHCI_HCD_OMAP is not set
 # CONFIG_USB_EHCI_HCD_PPC_OF is not set
index aa0b0e0b200b37f1d309dc980774e5793621f724..172af013dbee4a6e4d1b91d54bffc790ebc6fc97 100644 (file)
@@ -5501,6 +5501,7 @@ CONFIG_USB_DEFAULT_PERSIST=y
 # CONFIG_USB_DYNAMIC_MINORS is not set
 # CONFIG_USB_EG20T is not set
 # CONFIG_USB_EHCI_ATH79 is not set
+# CONFIG_USB_EHCI_HCD is not set
 # CONFIG_USB_EHCI_HCD_AT91 is not set
 # CONFIG_USB_EHCI_HCD_OMAP is not set
 # CONFIG_USB_EHCI_HCD_PPC_OF is not set
index aca72b8fae1d565488ed736ef8f584432df2143f..a9d3e6920afd4a66301d4340da97ed9c96efab08 100644 (file)
@@ -5873,6 +5873,7 @@ CONFIG_USB_DEFAULT_PERSIST=y
 # CONFIG_USB_EG20T is not set
 # CONFIG_USB_EHCI_ATH79 is not set
 # CONFIG_USB_EHCI_FSL is not set
+# CONFIG_USB_EHCI_HCD is not set
 # CONFIG_USB_EHCI_HCD_AT91 is not set
 # CONFIG_USB_EHCI_HCD_OMAP is not set
 # CONFIG_USB_EHCI_HCD_PPC_OF is not set
index c5ed939d76edfd0c1bbd9d5c491c980f2bc470c4..c50c03b5483de813704c973dd5e10c63ce4c532e 100644 (file)
@@ -18,6 +18,6 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
 
 $(eval $(call BuildTarget))
index da03efa94cc0790b4075166abc1773b3520a285f..a04bce9635596466cadf458438fdb2cec9f3c991 100644 (file)
@@ -342,12 +342,7 @@ CONFIG_UNWINDER_ARM=y
 # CONFIG_UNWINDER_FRAME_POINTER is not set
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
-# CONFIG_USB_EHCI_FSL is not set
-CONFIG_USB_EHCI_HCD=y
-CONFIG_USB_EHCI_HCD_ORION=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
 CONFIG_USB_LED_TRIG=y
-CONFIG_USB_STORAGE=y
 CONFIG_USB_SUPPORT=y
 CONFIG_USE_OF=y
 # CONFIG_VFP is not set