kirkwood: move mmc/sd features to modules
authorPawel Dembicki <paweldembicki@gmail.com>
Thu, 30 Apr 2020 10:27:09 +0000 (12:27 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 14 Jun 2020 19:16:20 +0000 (21:16 +0200)
All devices are using nand images. Built-in MMC/SD modules are not needed
anymore.

Run tested: pogo v4

Reviewed-by: Sungbo Eo <mans0n@gorani.run>
Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
package/kernel/linux/modules/other.mk
target/linux/kirkwood/config-5.4
target/linux/kirkwood/image/Makefile

index 2cd4765196888a81e04316c86cbe00af44b6a111..936a1327fd90ac3cc7906c385fb5d96dc9a416c7 100644 (file)
@@ -391,6 +391,23 @@ endef
 $(eval $(call KernelPackage,mmc))
 
 
+define KernelPackage/mvsdio
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Marvell MMC/SD/SDIO host driver
+  DEPENDS:=+kmod-mmc @TARGET_kirkwood
+  KCONFIG:= CONFIG_MMC_MVSDIO
+  FILES:= \
+       $(LINUX_DIR)/drivers/mmc/host/mvsdio.ko
+  AUTOLOAD:=$(call AutoProbe,mvsdio,1)
+endef
+
+define KernelPackage/mvsdio/description
+ Kernel support for the Marvell SDIO host driver.
+endef
+
+$(eval $(call KernelPackage,mvsdio))
+
+
 define KernelPackage/sdhci
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Secure Digital Host Controller Interface support
index 4be83a51396a6d525df44b06f77cf1ce1e3b2fac..da03efa94cc0790b4075166abc1773b3520a285f 100644 (file)
@@ -221,9 +221,6 @@ CONFIG_MDIO_BUS=y
 CONFIG_MDIO_DEVICE=y
 CONFIG_MEMFD_CREATE=y
 CONFIG_MIGRATION=y
-CONFIG_MMC=y
-CONFIG_MMC_BLOCK=y
-CONFIG_MMC_MVSDIO=y
 # CONFIG_MMC_TIFM_SD is not set
 CONFIG_MODULES_USE_ELF_REL=y
 # CONFIG_MTD_CFI is not set
index 76dfc4ea09bc4bc8ffdf4203edabdd577a4da6ec..85bf0118acec4ffa31233fc672ecfe8c281a3c93 100644 (file)
@@ -36,6 +36,7 @@ define Device/cisco_on100
   UBINIZE_OPTS := -E 5
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
   BOARD_NAME := on100
+  DEVICE_PACKAGES := kmod-mvsdio
 endef
 TARGET_DEVICES += cisco_on100
 
@@ -50,7 +51,7 @@ define Device/cloudengines_pogoplugv4
   DEVICE_VENDOR := Cloud Engines
   DEVICE_MODEL := Pogoplug V4
   DEVICE_DTS := kirkwood-pogoplug-series-4
-  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-usb3
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-mvsdio kmod-usb3
 endef
 TARGET_DEVICES += cloudengines_pogoplugv4