kernel: bump 4.14 to 4.14.144
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 18 Sep 2019 13:07:31 +0000 (15:07 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 20 Sep 2019 11:17:20 +0000 (13:17 +0200)
Refreshed all patches.

Fixes:
- CVE-2019-15030

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/204-module_strip.patch

index 83e8d7734d2f25093c77cdcd7cfeaeaa79e2770b..aaa1d1005d632666c7b06e355c3db6bdd39c5a4c 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .193
-LINUX_VERSION-4.14 = .143
+LINUX_VERSION-4.14 = .144
 
 LINUX_KERNEL_HASH-4.9.193 = 9be5081cc0fa6b720e6b3e5cb90296f3d857469bb3cda09ff93db00f9e16fd01
-LINUX_KERNEL_HASH-4.14.143 = 2534f2f03cb937700a03dd85dcf1cb6e6f46fdd29d489580cc3183d6c0643d93
+LINUX_KERNEL_HASH-4.14.144 = cb8b84675ba060b249ffa62de2366d16e842e3edfcb355ebbfb06bf3de03ca54
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index dce9c48473111e192e4505ae388f43555062c4c3..d847adf05451564081945677933687910001e621 100644 (file)
@@ -114,7 +114,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3008,9 +3008,11 @@ static struct module *setup_load_info(st
+@@ -3020,9 +3020,11 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -127,7 +127,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3031,6 +3033,7 @@ static int check_modinfo(struct module *
+@@ -3043,6 +3045,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }