kernel: bump 4.9 to 4.9.193
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 18 Sep 2019 13:05:34 +0000 (15:05 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 20 Sep 2019 11:17:20 +0000 (13:17 +0200)
Refreshed all patches.

Fixes:
- CVE-2019-15030

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/620-MIPS-ath79-add-support-for-QCA953x-SoC.patch
target/linux/ar71xx/patches-4.9/621-MIPS-ath79-add-support-for-QCA956x-SoC.patch
target/linux/ar71xx/patches-4.9/630-MIPS-ath79-fix-chained-irq-disable.patch
target/linux/generic/pending-4.9/343-MIPS-ath79-Fix-potentially-missed-IRQ-handling-durin.patch

index 63850cfef0092468ffb49b1ae6f4a259faf97b7b..83e8d7734d2f25093c77cdcd7cfeaeaa79e2770b 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .192
+LINUX_VERSION-4.9 = .193
 LINUX_VERSION-4.14 = .143
 
-LINUX_KERNEL_HASH-4.9.192 = 7a1a300cce70a4fd0d49b7fff7b1673159b61c4040c5a7c08ea333a7cb328d54
+LINUX_KERNEL_HASH-4.9.193 = 9be5081cc0fa6b720e6b3e5cb90296f3d857469bb3cda09ff93db00f9e16fd01
 LINUX_KERNEL_HASH-4.14.143 = 2534f2f03cb937700a03dd85dcf1cb6e6f46fdd29d489580cc3183d6c0643d93
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index ed887cc500923778c48ffdd65b2dd18d1242b0f7..e3b5d48d743b6206a678e3880d5b338a7a42615e 100644 (file)
@@ -307,7 +307,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
                return;
 --- a/arch/mips/ath79/irq.c
 +++ b/arch/mips/ath79/irq.c
-@@ -56,6 +56,34 @@ static void ar934x_ip2_irq_init(void)
+@@ -62,6 +62,34 @@ static void ar934x_ip2_irq_init(void)
        irq_set_chained_handler(ATH79_CPU_IRQ(2), ar934x_ip2_irq_dispatch);
  }
  
@@ -342,7 +342,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
  static void qca955x_ip2_irq_dispatch(struct irq_desc *desc)
  {
        u32 status;
-@@ -143,7 +171,7 @@ void __init arch_init_irq(void)
+@@ -149,7 +177,7 @@ void __init arch_init_irq(void)
            soc_is_ar913x() || soc_is_ar933x()) {
                irq_wb_chan2 = 3;
                irq_wb_chan3 = 2;
@@ -351,7 +351,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
                irq_wb_chan3 = 2;
        }
  
-@@ -154,6 +182,7 @@ void __init arch_init_irq(void)
+@@ -160,6 +188,7 @@ void __init arch_init_irq(void)
        else if (soc_is_ar724x() ||
                 soc_is_ar933x() ||
                 soc_is_ar934x() ||
@@ -359,7 +359,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
                 soc_is_qca955x())
                misc_is_ar71xx = false;
        else
-@@ -164,6 +193,8 @@ void __init arch_init_irq(void)
+@@ -170,6 +199,8 @@ void __init arch_init_irq(void)
  
        if (soc_is_ar934x())
                ar934x_ip2_irq_init();
index 03bb9c31f6e41527197c810409c3003a52118df3..20aa7ea27edc2c5c9d71121e2bb04d2246e1bf1d 100644 (file)
                return;
 --- a/arch/mips/ath79/irq.c
 +++ b/arch/mips/ath79/irq.c
-@@ -156,6 +156,87 @@ static void qca955x_irq_init(void)
+@@ -162,6 +162,87 @@ static void qca955x_irq_init(void)
        irq_set_chained_handler(ATH79_CPU_IRQ(3), qca955x_ip3_irq_dispatch);
  }
  
  void __init arch_init_irq(void)
  {
        unsigned irq_wb_chan2 = -1;
-@@ -183,7 +264,9 @@ void __init arch_init_irq(void)
+@@ -189,7 +270,9 @@ void __init arch_init_irq(void)
                 soc_is_ar933x() ||
                 soc_is_ar934x() ||
                 soc_is_qca953x() ||
                misc_is_ar71xx = false;
        else
                BUG();
-@@ -197,4 +280,6 @@ void __init arch_init_irq(void)
+@@ -203,4 +286,6 @@ void __init arch_init_irq(void)
                qca953x_irq_init();
        else if (soc_is_qca955x())
                qca955x_irq_init();
index 2b92b88d036f6ef9e4ac2b1ad93637229e8d7f85..a74eb4f43e2145ee8d0d681e76147dddc4c45329 100644 (file)
@@ -10,7 +10,7 @@
  static void ar934x_ip2_irq_dispatch(struct irq_desc *desc)
  {
        u32 status;
-@@ -50,8 +53,7 @@ static void ar934x_ip2_irq_init(void)
+@@ -56,8 +59,7 @@ static void ar934x_ip2_irq_init(void)
  
        for (i = ATH79_IP2_IRQ_BASE;
             i < ATH79_IP2_IRQ_BASE + ATH79_IP2_IRQ_COUNT; i++)
@@ -20,7 +20,7 @@
  
        irq_set_chained_handler(ATH79_CPU_IRQ(2), ar934x_ip2_irq_dispatch);
  }
-@@ -79,7 +81,7 @@ static void qca953x_irq_init(void)
+@@ -85,7 +87,7 @@ static void qca953x_irq_init(void)
  
        for (i = ATH79_IP2_IRQ_BASE;
             i < ATH79_IP2_IRQ_BASE + ATH79_IP2_IRQ_COUNT; i++)
@@ -29,7 +29,7 @@
  
        irq_set_chained_handler(ATH79_CPU_IRQ(2), qca953x_ip2_irq_dispatch);
  }
-@@ -143,15 +145,13 @@ static void qca955x_irq_init(void)
+@@ -149,15 +151,13 @@ static void qca955x_irq_init(void)
  
        for (i = ATH79_IP2_IRQ_BASE;
             i < ATH79_IP2_IRQ_BASE + ATH79_IP2_IRQ_COUNT; i++)
@@ -47,7 +47,7 @@
  
        irq_set_chained_handler(ATH79_CPU_IRQ(3), qca955x_ip3_irq_dispatch);
  }
-@@ -222,13 +222,13 @@ static void qca956x_irq_init(void)
+@@ -228,13 +228,13 @@ static void qca956x_irq_init(void)
  
        for (i = ATH79_IP2_IRQ_BASE;
             i < ATH79_IP2_IRQ_BASE + ATH79_IP2_IRQ_COUNT; i++)
@@ -63,7 +63,7 @@
  
        irq_set_chained_handler(ATH79_CPU_IRQ(3), qca956x_ip3_irq_dispatch);
  
-@@ -237,12 +237,40 @@ static void qca956x_irq_init(void)
+@@ -243,12 +243,40 @@ static void qca956x_irq_init(void)
        late_time_init = &qca956x_enable_timer_cb;
  }
  
index b1389bc28d9c27053bf9913df49f09a8828fcfe3..05a1d7ef0c3fb1ce58e059fa552586672ac86fc3 100644 (file)
@@ -23,11 +23,9 @@ CC: stable@vger.kernel.org # v3.2+
  arch/mips/ath79/irq.c | 12 +++++++++---
  1 file changed, 9 insertions(+), 3 deletions(-)
 
-diff --git a/arch/mips/ath79/irq.c b/arch/mips/ath79/irq.c
-index 2dfff1f19004..a03a6bcaf6fd 100644
 --- a/arch/mips/ath79/irq.c
 +++ b/arch/mips/ath79/irq.c
-@@ -32,15 +32,21 @@ static void ar934x_ip2_irq_dispatch(struct irq_desc *desc)
+@@ -32,15 +32,21 @@ static void ar934x_ip2_irq_dispatch(stru
        u32 status;
  
        status = ath79_reset_rr(AR934X_RESET_REG_PCIE_WMAC_INT_STATUS);
@@ -52,6 +50,3 @@ index 2dfff1f19004..a03a6bcaf6fd 100644
        }
  }
  
--- 
-2.17.1
-