kernel: bump 4.14 to 4.14.146
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 09:07:18 +0000 (11:07 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 10:53:40 +0000 (12:53 +0200)
Refreshed all patches.

Fixes:
- CVE-2019-14814
- CVE-2019-14815
- CVE-2019-14816
- CVE-2019-14821

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch

index 1dacb0a8fe69a64beb28ee90b575e809c3f37688..c8bbb61db1dcba5cf366ba1811c3758e4325865a 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .194
-LINUX_VERSION-4.14 = .145
+LINUX_VERSION-4.14 = .146
 
 LINUX_KERNEL_HASH-4.9.194 = d5f4bb7584e461f1faa9a3f94c2ad292246fe692b0e992e072dac255f806c2e3
-LINUX_KERNEL_HASH-4.14.145 = eb05b5806713263a6d5bfa1e018ad07c3f4b3c6e71032306a94d7113ed594929
+LINUX_KERNEL_HASH-4.14.146 = a3c54b887ea3e679382bd4c0536e6a281b071dab2258bd3ee8af75baef2023f5
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index d1e92ae40af4cb12a66a4d063833396ddf2b374e..59651c921a0237c3ffd78b9a11e9771b25334e3a 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  EXPORT_SYMBOL(default_qdisc_ops);
  
  /* Main transmission queue. */
-@@ -760,7 +760,7 @@ static void attach_one_default_qdisc(str
+@@ -764,7 +764,7 @@ static void attach_one_default_qdisc(str
                                     void *_unused)
  {
        struct Qdisc *qdisc;