kernel: bump 4.9 to 4.9.194
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 08:59:28 +0000 (10:59 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 24 Sep 2019 10:53:40 +0000 (12:53 +0200)
Refreshed all patches.

Fixes:
- CVE-2019-14814
- CVE-2019-14815
- CVE-2019-14816
- CVE-2019-14821

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar7/patches-4.9/300-add-ac49x-platform.patch
target/linux/ar71xx/patches-4.9/500-MIPS-fw-myloader.patch
target/linux/generic/hack-4.9/301-mips_image_cmdline_hack.patch
target/linux/generic/hack-4.9/661-use_fq_codel_by_default.patch
target/linux/generic/pending-4.9/300-mips_expose_boot_raw.patch
target/linux/generic/pending-4.9/304-mips_disable_fpu.patch
target/linux/generic/pending-4.9/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch
target/linux/lantiq/patches-4.9/0152-lantiq-VPE.patch
target/linux/layerscape/patches-4.9/810-iommu-support-layerscape.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch

index 9c1028122ab5a1b4ea83818265b982f42fe1fb0e..1dacb0a8fe69a64beb28ee90b575e809c3f37688 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .193
+LINUX_VERSION-4.9 = .194
 LINUX_VERSION-4.14 = .145
 
-LINUX_KERNEL_HASH-4.9.193 = 9be5081cc0fa6b720e6b3e5cb90296f3d857469bb3cda09ff93db00f9e16fd01
+LINUX_KERNEL_HASH-4.9.194 = d5f4bb7584e461f1faa9a3f94c2ad292246fe692b0e992e072dac255f806c2e3
 LINUX_KERNEL_HASH-4.14.145 = eb05b5806713263a6d5bfa1e018ad07c3f4b3c6e71032306a94d7113ed594929
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index ed1a8142459de732ba15cf7a92b315a4c110011b..8773ef98bbd9c89870889ba4798f7f11979cb45c 100644 (file)
@@ -46,7 +46,7 @@
  
  config ATH25
        bool "Atheros AR231x/AR531x SoC support"
-@@ -1009,6 +1009,7 @@ config MIPS_PARAVIRT
+@@ -1006,6 +1006,7 @@ config MIPS_PARAVIRT
  endchoice
  
  source "arch/mips/alchemy/Kconfig"
index 014b28658daf0b78aa0dd2eacf98c996f788a6e7..5b87d7a91e4a6adfb3c1ceec274fb35bc6a7e567 100644 (file)
@@ -10,7 +10,7 @@
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1154,6 +1154,9 @@ config MIPS_MSC
+@@ -1151,6 +1151,9 @@ config MIPS_MSC
  config MIPS_NILE4
        bool
  
index 4d90c0782109997c31fc0f0631387cae926d80a2..01caff5b89e87849282b3224d197f6cc692ff03d 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1160,6 +1160,10 @@ config SYNC_R4K
+@@ -1157,6 +1157,10 @@ config SYNC_R4K
  config MIPS_MACHINE
        def_bool n
  
index 34fc2a37c3f19c0f982a1c9a3ae0c047a3ce60da..5461393daa78c74db9fec8b0d9f84e4d061922e9 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  EXPORT_SYMBOL(default_qdisc_ops);
  
  /* Main transmission queue. */
-@@ -760,7 +760,7 @@ static void attach_one_default_qdisc(str
+@@ -764,7 +764,7 @@ static void attach_one_default_qdisc(str
                                     void *_unused)
  {
        struct Qdisc *qdisc;
index 5c4c6dacf3b2a62ca29443d924b833c11d62675b..f826bf557e328885f4cb493b8b9d0afb4cf19c05 100644 (file)
@@ -9,7 +9,7 @@ Acked-by: Rob Landley <rob@landley.net>
 ---
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1069,9 +1069,6 @@ config FW_ARC
+@@ -1066,9 +1066,6 @@ config FW_ARC
  config ARCH_MAY_HAVE_PC_FDC
        bool
  
@@ -19,7 +19,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -2968,6 +2965,18 @@ choice
+@@ -2965,6 +2962,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index aac9c79da850c62d28e49b527dedb344a684cad1..4765da72def6b3b9d5506e621cee80395bc6d289 100644 (file)
@@ -24,7 +24,7 @@ v2: incorporated changes suggested by Jonas Gorski
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2892,6 +2892,20 @@ config MIPS_O32_FP64_SUPPORT
+@@ -2889,6 +2889,20 @@ config MIPS_O32_FP64_SUPPORT
  
          If unsure, say N.
  
index 0393b4a227e24d6e07bae21d39a084826ed2915e..19f5d294c8ee323f4aa1782b5d26d51fa8f6518d 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        select HAVE_PCSPKR_PLATFORM
        select IRQ_MIPS_CPU
        select I8253
-@@ -1130,6 +1132,9 @@ config DMA_NONCOHERENT
+@@ -1127,6 +1129,9 @@ config DMA_NONCOHERENT
        bool
        select NEED_DMA_MAP_STATE
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config NEED_DMA_MAP_STATE
        bool
  
-@@ -1654,6 +1659,7 @@ config CPU_R10000
+@@ -1651,6 +1656,7 @@ config CPU_R10000
        select CPU_SUPPORTS_64BIT_KERNEL
        select CPU_SUPPORTS_HIGHMEM
        select CPU_SUPPORTS_HUGEPAGES
@@ -48,7 +48,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
          MIPS Technologies R10000-series processors.
  
-@@ -1899,9 +1905,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
+@@ -1896,9 +1902,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
        bool
  
  config SYS_HAS_CPU_MIPS32_R5
@@ -60,7 +60,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        bool
  
  config SYS_HAS_CPU_MIPS64_R1
-@@ -1911,6 +1919,7 @@ config SYS_HAS_CPU_MIPS64_R2
+@@ -1908,6 +1916,7 @@ config SYS_HAS_CPU_MIPS64_R2
        bool
  
  config SYS_HAS_CPU_MIPS64_R6
index c3d9e7ff8966ecaf07d887cad397c1e8b0cc561b..ab69ca0903b816eb2bc5a37379fa2cfc2c09224c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2325,6 +2325,12 @@ config MIPS_VPE_LOADER
+@@ -2322,6 +2322,12 @@ config MIPS_VPE_LOADER
          Includes a loader for loading an elf relocatable object
          onto another VPE and running it.
  
index 9d11b3b805e21a305416801bd70a1b2c5e0af909..bed4a025f7b68c1933fc0c437744399a0b3bc7d1 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        return entry->group;
  }
-@@ -3185,9 +3187,10 @@ static bool amd_iommu_capable(enum iommu
+@@ -3191,9 +3193,10 @@ static bool amd_iommu_capable(enum iommu
        return false;
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct unity_map_entry *entry;
        int devid;
  
-@@ -3196,41 +3199,56 @@ static void amd_iommu_get_dm_regions(str
+@@ -3202,41 +3205,56 @@ static void amd_iommu_get_dm_regions(str
                return;
  
        list_for_each_entry(entry, &amd_iommu_unity_map, list) {
@@ -118,7 +118,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  {
        struct dma_ops_domain *dma_dom = to_dma_ops_domain(to_pdomain(domain));
        unsigned long start, end;
-@@ -3254,9 +3272,9 @@ static const struct iommu_ops amd_iommu_
+@@ -3260,9 +3278,9 @@ static const struct iommu_ops amd_iommu_
        .add_device = amd_iommu_add_device,
        .remove_device = amd_iommu_remove_device,
        .device_group = amd_iommu_device_group,
index 47a7027dbc12cd3359a31d9205eedd885eb3dd5f..2b9d3fefbe272d4cfb2065808c2380bda4c706d0 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/net/usb/cdc_ether.c
 +++ b/drivers/net/usb/cdc_ether.c
-@@ -533,6 +533,7 @@ static const struct driver_info wwan_inf
+@@ -540,6 +540,7 @@ static const struct driver_info wwan_inf
  #define LINKSYS_VENDOR_ID     0x13b1
  #define NVIDIA_VENDOR_ID      0x0955
  #define HP_VENDOR_ID          0x03f0
@@ -52,7 +52,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
  static const struct usb_device_id     products[] = {
  /* BLACKLIST !!
-@@ -742,6 +743,13 @@ static const struct usb_device_id produc
+@@ -749,6 +750,13 @@ static const struct usb_device_id produc
                        USB_CDC_SUBCLASS_ETHERNET, USB_CDC_PROTO_NONE),
        .driver_info = 0,
  },
@@ -76,7 +76,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
  #define MCU_TYPE_PLA                  0x0100
  #define MCU_TYPE_USB                  0x0000
-@@ -1817,6 +1818,10 @@ static int rx_bottom(struct r8152 *tp, i
+@@ -1820,6 +1821,10 @@ static int rx_bottom(struct r8152 *tp, i
                        unsigned int pkt_len;
                        struct sk_buff *skb;
  
@@ -87,7 +87,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                        pkt_len = le32_to_cpu(rx_desc->opts1) & RX_LEN_MASK;
                        if (pkt_len < ETH_ZLEN)
                                break;
-@@ -4513,6 +4518,7 @@ static struct usb_device_id rtl8152_tabl
+@@ -4516,6 +4521,7 @@ static struct usb_device_id rtl8152_tabl
        {REALTEK_USB_DEVICE(VENDOR_ID_LENOVO,  0x304f)},
        {REALTEK_USB_DEVICE(VENDOR_ID_LINKSYS, 0x0041)},
        {REALTEK_USB_DEVICE(VENDOR_ID_NVIDIA,  0x09ff)},