kirkwood: tidy up image Makefile
authorSungbo Eo <mans0n@gorani.run>
Sun, 23 Feb 2020 15:16:16 +0000 (00:16 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 23 Feb 2020 18:59:45 +0000 (19:59 +0100)
- use k in SIZE variables
- break long lines

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/kirkwood/image/Makefile

index cbdfbc11eccabef53f1c7348271fb139dd561472..92188854a31a648083620cffcd210aab7cf48ace 100644 (file)
@@ -70,12 +70,13 @@ define Device/iom_ix2-200
   DEVICE_TYPE:=nas
   PAGESIZE := 512
   SUBPAGESIZE := 256
-  BLOCKSIZE := 16KiB
+  BLOCKSIZE := 16k
   KERNEL_SIZE := 3072k
   KERNEL_IN_UBI :=
   UBINIZE_OPTS := -E 5
-  IMAGE_SIZE := 32505856
-  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+  IMAGE_SIZE := 31744k
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | \
+       check-size $$$$(IMAGE_SIZE)
 endef
 TARGET_DEVICES += iom_ix2-200
 
@@ -85,7 +86,7 @@ define Device/linksys_audi
   DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-basic kmod-gpio-button-hotplug
   PAGESIZE := 512
   SUBPAGESIZE := 256
-  BLOCKSIZE := 16KiB
+  BLOCKSIZE := 16k
   KERNEL_SIZE := 2624k
   KERNEL_IN_UBI :=
   UBINIZE_OPTS := -E 5