kirkwood: fix device node name of Iomega ix2-200
authorSungbo Eo <mans0n@gorani.run>
Sun, 23 Feb 2020 15:12:23 +0000 (00:12 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 23 Feb 2020 18:53:28 +0000 (19:53 +0100)
The current device node name of ix2-200 is "iom_ix2_200", which results
in a SUPPORTED_DEVICES string "iom,ix2,200" that does not match the
compatible in DTS and the board name used in board.d.

Fix this by replacing the second underscore with a dash, following
vendor_model scheme.

Fixes: 27b2f0fc0fc5 ("kirkwood: add support for Iomega Storcenter ix2-200")

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
[commit title/message rephrase]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/kirkwood/image/Makefile

index 9c5681901c04d173da8eb11487549abb2baa558e..cbdfbc11eccabef53f1c7348271fb139dd561472 100644 (file)
@@ -62,7 +62,7 @@ define Device/iom_iconnect-1.1
 endef
 TARGET_DEVICES += iom_iconnect-1.1
 
-define Device/iom_ix2_200
+define Device/iom_ix2-200
   DEVICE_VENDOR := Iomega
   DEVICE_MODEL := StorCenter ix2-200
   DEVICE_DTS := kirkwood-iomega_ix2_200
@@ -77,7 +77,7 @@ define Device/iom_ix2_200
   IMAGE_SIZE := 32505856
   IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
 endef
-TARGET_DEVICES += iom_ix2_200
+TARGET_DEVICES += iom_ix2-200
 
 define Device/linksys_audi
   DEVICE_VENDOR := Linksys