remove CYGWIN codeblocks, drop vendored Windows openvpn, drop win32 specific files.
[oweals/gnunet.git] / src / util / Makefile.am
index 647f09224fe2676c78a567a364e410d90735d275..c240053ff1cce173180d369edd6af62897b15f2a 100644 (file)
@@ -13,27 +13,7 @@ dist_pkgcfg_DATA = \
 pkgcfg_DATA = \
   resolver.conf
 
-if MINGW
-noinst_LTLIBRARIES = \
-  libgnunetutilwin.la
-libgnunetutilwin_la_SOURCES = \
-  win.c \
-  winproc.c
-libgnunetutilwin_la_LDFLAGS = \
-  -no-undefined -Wl,--export-all-symbols
-libgnunetutilwin_la_LIBADD = \
-  -lshell32 -liconv -lstdc++ \
-  -lcomdlg32 -lgdi32 -liphlpapi
-WINLIB = libgnunetutilwin.la
-W32CAT = w32cat
-W32CONSOLEHELPER = gnunet-helper-w32-console
-endif
-
-if !MINGW
- TEST_CLIENT_UNIX_NC = test_client_unix.nc
-else
- TEST_CLIENT_UNIX_NC =
-endif
+TEST_CLIENT_UNIX_NC = test_client_unix.nc
 
 if USE_COVERAGE
   AM_CFLAGS = --coverage -O0
@@ -45,14 +25,6 @@ if ENABLE_BENCHMARK
   PTHREAD = -lpthread
 endif
 
-w32cat_SOURCES = w32cat.c
-
-gnunet_helper_w32_console_SOURCES = \
-  gnunet-helper-w32-console.c \
-  gnunet-helper-w32-console.h
-gnunet_helper_w32_console_LDADD = \
-  libgnunetutil.la
-
 gnunet_config_diff_SOURCES = \
  gnunet-config-diff.c
 gnunet_config_diff_LDADD = \
@@ -202,8 +174,7 @@ lib_LTLIBRARIES = libgnunetutil.la
 
 libexec_PROGRAMS = \
  gnunet-service-resolver \
- gnunet-timeout \
- $(W32CONSOLEHELPER)
+ gnunet-timeout
 
 bin_PROGRAMS = \
  gnunet-resolver \
@@ -217,7 +188,6 @@ endif
 
 noinst_PROGRAMS = \
  gnunet-config-diff \
- $(W32CAT) \
  test_common_logging_dummy
 
 
@@ -228,14 +198,8 @@ endif
 
 endif
 
-
-if !MINGW
 gnunet_timeout_SOURCES = \
  gnunet-timeout.c
-else
-gnunet_timeout_SOURCES = \
- gnunet-timeout-w32.c
-endif
 
 gnunet_service_resolver_SOURCES = \
  gnunet-service-resolver.c
@@ -393,8 +357,7 @@ test_os_start_process_SOURCES = \
 test_os_start_process_LDADD = \
  libgnunetutil.la
 test_os_start_process_DEPENDENCIES = \
- libgnunetutil.la \
- $(WINCAT)
+ libgnunetutil.la
 
 test_client_nc_SOURCES = \
  test_client.c