fix more 'make dist' issues
[oweals/gnunet.git] / src / dht / Makefile.am
index 147248234f3bf2f5b098e3f4961af34e344497ff..d60ff62d6146e3e03d65b9555518924455bc1415 100644 (file)
@@ -1,13 +1,17 @@
-INCLUDES = -I$(top_srcdir)/src/include
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include
 if MINGW
  WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols -lole32 -lshell32 -liconv -lstdc++ -lcomdlg32 -lgdi32
 endif
 
 plugindir = $(libdir)/gnunet
 
-if HAVE_ZLIB
- ZLIB_LNK = -lz
-endif
+pkgcfgdir= $(pkgdatadir)/config.d/
+
+libexecdir= $(pkglibdir)/libexec/
+
+pkgcfg_DATA = \
+  dht.conf
 
 if USE_COVERAGE
   AM_CFLAGS = --coverage -O0
@@ -15,52 +19,59 @@ if USE_COVERAGE
 endif
 
 lib_LTLIBRARIES = \
- libgnunetdht.la \
- libgnunetdhtnew.la 
-
+ libgnunetdht.la
 
 libgnunetdht_la_SOURCES = \
-  dht_api.c dht.h \
-  dht_api_get_put.c \
-  dht_api_find_peer.c 
+  dht_api.c dht.h
 libgnunetdht_la_LIBADD = \
   $(top_builddir)/src/util/libgnunetutil.la \
-  $(XLIB)
+  $(XLIB) \
+  $(LTLIBINTL)
 libgnunetdht_la_LDFLAGS = \
   $(GN_LIB_LDFLAGS) $(WINFLAGS) \
-  -version-info 0:0:0
+  -version-info 3:0:0
+
+
+plugin_LTLIBRARIES = \
+  libgnunet_plugin_block_dht.la
 
-libgnunetdhtnew_la_SOURCES = \
-  dht_api_new.c dht_new.h 
-libgnunetdhtnew_la_LIBADD = \
+libgnunet_plugin_block_dht_la_SOURCES = \
+  plugin_block_dht.c
+libgnunet_plugin_block_dht_la_LIBADD = \
+  $(top_builddir)/src/hello/libgnunethello.la \
+  $(top_builddir)/src/block/libgnunetblock.la \
+  $(top_builddir)/src/block/libgnunetblockgroup.la \
   $(top_builddir)/src/util/libgnunetutil.la \
-  $(XLIB)
-libgnunetdhtnew_la_LDFLAGS = \
-  $(GN_LIB_LDFLAGS) $(WINFLAGS) \
-  -version-info 0:0:0
+  $(LTLIBINTL)
+libgnunet_plugin_block_dht_la_LDFLAGS = \
+ $(GN_PLUGIN_LDFLAGS)
+
+
+libexec_PROGRAMS = \
+ gnunet-service-dht
 
 bin_PROGRAMS = \
- gnunet-service-dht-new \
+ gnunet-dht-monitor \
  gnunet-dht-get \
  gnunet-dht-put
 
-if HAVE_MALICIOUS
+if HAVE_TESTING
 noinst_PROGRAMS = \
- gnunet-dht-driver 
+ gnunet-dht-profiler
 endif
 
-gnunet_service_dht_new_SOURCES = \
- gnunet-service-dht-new.c gnunet-service-dht.h \
- gnunet-service-dht_clients.c gnunet-service-dht_clients.h \
+gnunet_service_dht_SOURCES = \
+ gnunet-service-dht.c gnunet-service-dht.h \
  gnunet-service-dht_datacache.c gnunet-service-dht_datacache.h \
  gnunet-service-dht_hello.c gnunet-service-dht_hello.h \
  gnunet-service-dht_nse.c gnunet-service-dht_nse.h \
  gnunet-service-dht_neighbours.c gnunet-service-dht_neighbours.h \
- gnunet-service-dht_routing.c gnunet-service-dht_routing.h 
-gnunet_service_dht_new_LDADD = \
+ gnunet-service-dht_routing.c gnunet-service-dht_routing.h
+gnunet_service_dht_LDADD = \
   $(top_builddir)/src/statistics/libgnunetstatistics.la \
   $(top_builddir)/src/core/libgnunetcore.la \
   $(top_builddir)/src/nse/libgnunetnse.la \
+  $(top_builddir)/src/ats/libgnunetats.la \
   $(top_builddir)/src/transport/libgnunettransport.la \
   $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
   $(top_builddir)/src/hello/libgnunethello.la \
@@ -70,95 +81,144 @@ gnunet_service_dht_new_LDADD = \
   -lm
 
 gnunet_dht_get_SOURCES = \
- gnunet-dht-get.c         
+ gnunet-dht-get.c
 gnunet_dht_get_LDADD = \
-  $(top_builddir)/src/dht/libgnunetdhtnew.la \
+  libgnunetdht.la \
   $(top_builddir)/src/core/libgnunetcore.la \
-  $(top_builddir)/src/util/libgnunetutil.la 
-gnunet_dht_get_DEPENDENCIES = \
-  libgnunetdht.la                            
+  $(top_builddir)/src/util/libgnunetutil.la
 
 gnunet_dht_put_SOURCES = \
- gnunet-dht-put.c         
+ gnunet-dht-put.c
 gnunet_dht_put_LDADD = \
-  $(top_builddir)/src/dht/libgnunetdhtnew.la \
+  libgnunetdht.la \
   $(top_builddir)/src/core/libgnunetcore.la \
-  $(top_builddir)/src/util/libgnunetutil.la 
-gnunet_dht_put_DEPENDENCIES = \
-  libgnunetdht.la                            
+  $(top_builddir)/src/util/libgnunetutil.la
 
+gnunet_dht_monitor_SOURCES = \
+ gnunet-dht-monitor.c
+gnunet_dht_monitor_LDADD = \
+  libgnunetdht.la \
+  $(top_builddir)/src/core/libgnunetcore.la \
+  $(top_builddir)/src/util/libgnunetutil.la
+
+gnunet_dht_profiler_SOURCES = \
+  gnunet_dht_profiler.c
+gnunet_dht_profiler_LDADD = \
+  libgnunetdht.la \
+  $(top_builddir)/src/core/libgnunetcore.la \
+  $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la
+
+if HAVE_TESTING
+noinst_LIBRARIES = libgnunetdhttest.a
+endif
+
+libgnunetdhttest_a_SOURCES = \
+  dht_test_lib.c dht_test_lib.h
+libgnunetdhttest_a_LIBADD = \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ libgnunetdht.la
+
+if HAVE_TESTING
 check_PROGRAMS = \
  test_dht_api \
  test_dht_twopeer \
- test_dht_twopeer_put_get \
- test_dht_twopeer_get_put \
- test_dht_twopeer_path_tracking \
- test_dht_multipeer 
+ test_dht_multipeer \
+ test_dht_line \
+ test_dht_2dtorus \
+ test_dht_monitor
+endif
+
+if HAVE_EXPERIMENTAL
+# These tests still do not work as testbed does
+# not support the respective topology op
+ NEW_TESTS = test_dht_2dtorus test_dht_multipeer
+endif
 
 if ENABLE_TEST_RUN
+AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
 TESTS = test_dht_api $(check_SCRIPTS) \
  test_dht_twopeer \
- test_dht_twopeer_put_get \
- test_dht_twopeer_get_put \
- test_dht_twopeer_path_tracking \
- test_dht_multipeer 
+ test_dht_line \
+ test_dht_monitor \
+ $(NEW_TESTS)
 endif
 
 test_dht_api_SOURCES = \
  test_dht_api.c
 test_dht_api_LDADD = \
- $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/hello/libgnunethello.la \
- $(top_builddir)/src/dht/libgnunetdhtnew.la
-test_dht_api_DEPENDENCIES = \
-  libgnunetdht.la                          
-
-test_dht_multipeer_SOURCES = \
- test_dht_multipeer.c
-test_dht_multipeer_LDADD = \
  $(top_builddir)/src/util/libgnunetutil.la \
  $(top_builddir)/src/testing/libgnunettesting.la \
- $(top_builddir)/src/dht/libgnunetdht.la  
-test_dht_multipeer_DEPENDENCIES = \
-  libgnunetdht.la                          
+ $(top_builddir)/src/hello/libgnunethello.la \
+ libgnunetdht.la
 
 test_dht_twopeer_SOURCES = \
- test_dht_twopeer.c
+ test_dht_topo.c
 test_dht_twopeer_LDADD = \
+ libgnunetdhttest.a \
  $(top_builddir)/src/util/libgnunetutil.la \
$(top_builddir)/src/testing/libgnunettesting.la \
- $(top_builddir)/src/dht/libgnunetdhtnew.la    
-test_dht_twopeer_DEPENDENCIES = \
-  libgnunetdht.la                          
-
-test_dht_twopeer_put_get_SOURCES = \
- test_dht_twopeer_put_get.c
-test_dht_twopeer_put_get_LDADD = \
libgnunetdhttest.a \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ libgnunetdht.la
+
+test_dht_2dtorus_SOURCES = \
+ test_dht_topo.c
+test_dht_2dtorus_LDADD = \
+ libgnunetdhttest.a \
  $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la \
- $(top_builddir)/src/dht/libgnunetdhtnew.la   
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ libgnunetdht.la
 
-test_dht_twopeer_get_put_SOURCES = \
- test_dht_twopeer_get_put.c
-test_dht_twopeer_get_put_LDADD = \
+test_dht_line_SOURCES = \
+ test_dht_topo.c
+test_dht_line_LDADD = \
+ libgnunetdhttest.a \
  $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la \
- $(top_builddir)/src/dht/libgnunetdhtnew.la   
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ libgnunetdht.la
 
-test_dht_twopeer_path_tracking_SOURCES = \
- test_dht_twopeer_path_tracking.c
-test_dht_twopeer_path_tracking_LDADD = \
+test_dht_multipeer_SOURCES = \
+ test_dht_topo.c
+test_dht_multipeer_LDADD = \
+ libgnunetdhttest.a \
  $(top_builddir)/src/util/libgnunetutil.la \
- $(top_builddir)/src/testing/libgnunettesting.la \
- $(top_builddir)/src/dht/libgnunetdht.la   
+ $(top_builddir)/src/statistics/libgnunetstatistics.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ libgnunetdht.la
+
+test_dht_monitor_SOURCES = \
+  test_dht_monitor.c
+test_dht_monitor_LDADD = \
+ libgnunetdhttest.a \
+ $(top_builddir)/src/util/libgnunetutil.la \
+ $(top_builddir)/src/testbed/libgnunettestbed.la \
+ libgnunetdht.la
 
 EXTRA_DIST = \
   $(check_SCRIPTS) \
+  gnunet-service-dht_clients.c \
   test_dht_api_data.conf \
   test_dht_api_peer1.conf \
-  test_dht_twopeer_data.conf \
-  test_dht_multipeer_data.conf \
-  multipeer_topo.dat
-
+  test_dht_monitor.conf \
+  test_dht_multipeer.conf \
+  test_dht_2dtorus.conf \
+  test_dht_line.conf \
+  test_dht_tools.py.in \
+  test_dht_multipeer_topology.dat
+
+if HAVE_PYTHON
 check_SCRIPTS = \
-  test_dht_tools.sh
+  test_dht_tools.py
+endif
+
+do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g' -e 's,[@]bindir[@],$(bindir),g'
+
+SUFFIXES = .py.in .py
+.py.in.py:
+       $(do_subst) < $(srcdir)/$< > $@
+       chmod +x $@
+
+test_dht_tools.py: test_dht_tools.py.in Makefile
+       $(do_subst) < $(srcdir)/test_dht_tools.py.in > test_dht_tools.py
+       chmod +x test_dht_tools.py