fix misc make dist issues
[oweals/gnunet.git] / src / Makefile.am
index f97283d0a754848a0f3f683f35ce3fb1ed10ad89..7f1a00177b170223446dddb612f9c0117c0d06aa 100644 (file)
@@ -1,38 +1,79 @@
+# This Makefile.am is in the public domain
 #if WANT_FRAMEWORK
 #  INTLEMU_SUBDIRS = intlemu
 #endif
 
 if HAVE_TESTING
  TESTING = testing
- TESTBED = testbed
- CONSENSUS = consensus
- EXPERIMENTATION = experimentation
+ TESTBED = testbed-logger testbed
+ ATS_TESTS = ats-tests
 endif
 
 if HAVE_EXPERIMENTAL
- EXP_DIR = dv $(CONSENSUS) $(EXPERIMENTATION)
+ EXP_DIR = \
+  rps
 endif
 
-if LINUX
-# All of these currently only work on GNU/Linux or W32
- LINUX_DIR = exit vpn pt
+if HAVE_JSON
+if HAVE_MHD
+  PROVIDER_DIR = identity-provider
 endif
-if MINGW
- MINGW_DIR = vpn exit pt
+endif
+
+if HAVE_JSON
+  JSON_DIR = json
+if HAVE_LIBGNURL
+  JSON_DIR += curl
+else
+if HAVE_LIBCURL
+  JSON_DIR += curl
+endif
+endif
+endif
+
+if BUILD_PULSE_HELPERS
+CONVERSATION_DIR = conversation
+else
+if BUILD_GST_HELPERS
+CONVERSATION_DIR = conversation
+endif
+endif
+
+if HAVE_SQLITE
+ SQLITE_DIR = sq
 endif
 
 if HAVE_MYSQL
- MYSQL_DIR = mysql
+ MYSQL_DIR = mysql my
 endif
 
-if HAVE_POSTGRES
- POSTGRES_DIR = postgres
+if HAVE_POSTGRESQL
+ POSTGRES_DIR = pq
 endif
 
+if HAVE_MHD
+ REST_DIR = rest
+if HAVE_JSON
+ JSONAPI_DIR = jsonapi
+endif
+endif
+
+if HAVE_JSON
+  AUCTION_DIR = auction
+endif
+
+if TALER_ONLY
+SUBDIRS = \
+ include \
+ util
+else
 
 SUBDIRS = \
   include $(INTLEMU_SUBDIRS) \
   util \
+  $(JSON_DIR) \
+  $(REST_DIR) \
+  $(JSONAPI_DIR) \
   hello \
   tun \
   block \
@@ -40,33 +81,54 @@ SUBDIRS = \
   arm \
   $(TESTING) \
   peerinfo \
+  $(SQLITE_DIR) \
   $(MYSQL_DIR) \
   $(POSTGRES_DIR) \
   datacache \
   datastore \
-  namestore \
   template \
   ats \
   nat \
+  nat-auto \
   fragmentation \
   transport \
   ats-tool \
   peerinfo-tool \
   core \
   $(TESTBED) \
+  $(ATS_TESTS) \
   nse \
   dht \
   hostlist \
   topology \
   regex \
-  mesh \
-  lockmanager \
-  stream \
   dns \
-  gns \
+  identity \
+  gnsrecord \
+  namecache \
+  namestore \
+  peerstore \
+  cadet \
   set \
+  consensus \
+  scalarproduct \
+  revocation \
+  vpn \
+  gns \
+  zonemaster \
+  $(CONVERSATION_DIR) \
   fs \
-  $(LINUX_DIR) \
-  $(MINGW_DIR) \
+  exit \
+  pt \
+  secretsharing \
   integration-tests \
-  $(EXP_DIR) 
+  multicast \
+  psycutil \
+  psycstore \
+  psyc \
+  social \
+  $(AUCTION_DIR) \
+  $(EXP_DIR) \
+  $(PROVIDER_DIR)
+
+endif