fix misc make dist issues
[oweals/gnunet.git] / src / Makefile.am
index 6925788d54a71d1c49d0b6c43f67e180dbbd01ac..7f1a00177b170223446dddb612f9c0117c0d06aa 100644 (file)
@@ -6,17 +6,12 @@
 if HAVE_TESTING
  TESTING = testing
  TESTBED = testbed-logger testbed
- CONSENSUS = consensus
- SECRETSHARING = secretsharing
+ ATS_TESTS = ats-tests
 endif
 
 if HAVE_EXPERIMENTAL
  EXP_DIR = \
-  dv \
-  rps \
-  $(CONSENSUS) \
-  $(SECRETSHARING)
-
+  rps
 endif
 
 if HAVE_JSON
@@ -44,12 +39,16 @@ CONVERSATION_DIR = conversation
 endif
 endif
 
+if HAVE_SQLITE
+ SQLITE_DIR = sq
+endif
+
 if HAVE_MYSQL
  MYSQL_DIR = mysql my
 endif
 
 if HAVE_POSTGRESQL
- POSTGRES_DIR = pq postgres
+ POSTGRES_DIR = pq
 endif
 
 if HAVE_MHD
@@ -59,6 +58,10 @@ if HAVE_JSON
 endif
 endif
 
+if HAVE_JSON
+  AUCTION_DIR = auction
+endif
+
 if TALER_ONLY
 SUBDIRS = \
  include \
@@ -78,6 +81,7 @@ SUBDIRS = \
   arm \
   $(TESTING) \
   peerinfo \
+  $(SQLITE_DIR) \
   $(MYSQL_DIR) \
   $(POSTGRES_DIR) \
   datacache \
@@ -85,13 +89,14 @@ SUBDIRS = \
   template \
   ats \
   nat \
+  nat-auto \
   fragmentation \
   transport \
   ats-tool \
   peerinfo-tool \
   core \
   $(TESTBED) \
-  ats-tests \
+  $(ATS_TESTS) \
   nse \
   dht \
   hostlist \
@@ -105,6 +110,7 @@ SUBDIRS = \
   peerstore \
   cadet \
   set \
+  consensus \
   scalarproduct \
   revocation \
   vpn \
@@ -114,12 +120,14 @@ SUBDIRS = \
   fs \
   exit \
   pt \
+  secretsharing \
   integration-tests \
   multicast \
   psycutil \
   psycstore \
   psyc \
   social \
+  $(AUCTION_DIR) \
   $(EXP_DIR) \
   $(PROVIDER_DIR)