fix misc make dist issues
[oweals/gnunet.git] / src / Makefile.am
index 18f8aeef2de705d70b1e32eb4fcf504fe6073a55..7f1a00177b170223446dddb612f9c0117c0d06aa 100644 (file)
@@ -1,34 +1,35 @@
+# This Makefile.am is in the public domain
 #if WANT_FRAMEWORK
 #  INTLEMU_SUBDIRS = intlemu
 #endif
 
 if HAVE_TESTING
  TESTING = testing
- TESTBED = testbed
- CONSENSUS = consensus
- SECRETSHARING = secretsharing
- EXPERIMENTATION = experimentation
- SCALARPRODUCT = scalarproduct
- SENSOR = sensor
- SENSORDASHBOARD = sensordashboard
+ TESTBED = testbed-logger testbed
+ ATS_TESTS = ats-tests
 endif
 
 if HAVE_EXPERIMENTAL
  EXP_DIR = \
-  dv \
-  multicast \
-  env \
-  psycstore \
-  psyc \
-  social \
-  $(CONSENSUS) \
-  $(SECRETSHARING) \
-  $(SCALARPRODUCT) \
-  $(EXPERIMENTATION) \
-  $(SENSOR) \
-  $(SENSORDASHBOARD)
+  rps
 endif
 
+if HAVE_JSON
+if HAVE_MHD
+  PROVIDER_DIR = identity-provider
+endif
+endif
+
+if HAVE_JSON
+  JSON_DIR = json
+if HAVE_LIBGNURL
+  JSON_DIR += curl
+else
+if HAVE_LIBCURL
+  JSON_DIR += curl
+endif
+endif
+endif
 
 if BUILD_PULSE_HELPERS
 CONVERSATION_DIR = conversation
@@ -38,17 +39,41 @@ CONVERSATION_DIR = conversation
 endif
 endif
 
+if HAVE_SQLITE
+ SQLITE_DIR = sq
+endif
+
 if HAVE_MYSQL
- MYSQL_DIR = mysql
+ MYSQL_DIR = mysql my
 endif
 
 if HAVE_POSTGRESQL
- POSTGRES_DIR = postgres
+ POSTGRES_DIR = pq
+endif
+
+if HAVE_MHD
+ REST_DIR = rest
+if HAVE_JSON
+ JSONAPI_DIR = jsonapi
+endif
+endif
+
+if HAVE_JSON
+  AUCTION_DIR = auction
 endif
 
+if TALER_ONLY
+SUBDIRS = \
+ include \
+ util
+else
+
 SUBDIRS = \
   include $(INTLEMU_SUBDIRS) \
   util \
+  $(JSON_DIR) \
+  $(REST_DIR) \
+  $(JSONAPI_DIR) \
   hello \
   tun \
   block \
@@ -56,6 +81,7 @@ SUBDIRS = \
   arm \
   $(TESTING) \
   peerinfo \
+  $(SQLITE_DIR) \
   $(MYSQL_DIR) \
   $(POSTGRES_DIR) \
   datacache \
@@ -63,32 +89,46 @@ SUBDIRS = \
   template \
   ats \
   nat \
+  nat-auto \
   fragmentation \
   transport \
   ats-tool \
   peerinfo-tool \
   core \
   $(TESTBED) \
-  ats-tests \
+  $(ATS_TESTS) \
   nse \
   dht \
   hostlist \
   topology \
   regex \
-  cadet \
   dns \
   identity \
-  set \
-  revocation \
   gnsrecord \
   namecache \
   namestore \
+  peerstore \
+  cadet \
+  set \
+  consensus \
+  scalarproduct \
+  revocation \
   vpn \
   gns \
+  zonemaster \
   $(CONVERSATION_DIR) \
-  peerstore \
   fs \
   exit \
   pt \
+  secretsharing \
   integration-tests \
-  $(EXP_DIR)
+  multicast \
+  psycutil \
+  psycstore \
+  psyc \
+  social \
+  $(AUCTION_DIR) \
+  $(EXP_DIR) \
+  $(PROVIDER_DIR)
+
+endif