build: show make output in scripts/config when V=s
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Fri, 17 Apr 2020 23:57:06 +0000 (20:57 -0300)
committerPetr Štetiar <ynezz@true.cz>
Wed, 20 May 2020 15:03:45 +0000 (17:03 +0200)
This should make debugging build errors in scripts/config a bit easier.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
include/toplevel.mk

index 2965f75c7cd7e66fef5b7562a77f134ff6ddb18f..ad8e5b8f20428e7b81054e367dbc782258f0d43a 100644 (file)
@@ -104,7 +104,8 @@ scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
 endif
 scripts/config/%onf: CFLAGS+= -O2
 scripts/config/%onf:
 endif
 scripts/config/%onf: CFLAGS+= -O2
 scripts/config/%onf:
-       @$(_SINGLE)$(SUBMAKE) -s -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
+       @$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
+               -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
 
 $(eval $(call rdep,scripts/config,scripts/config/mconf))
 
 
 $(eval $(call rdep,scripts/config,scripts/config/mconf))