bcm63xx: vg-8050: switch to bcm-wfi-split
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 2 Jun 2020 16:04:45 +0000 (18:04 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 2 Jun 2020 16:25:44 +0000 (18:25 +0200)
Allows to keep a backup firmware in case active firmware is corrupted.
Also fix hsspi address warning.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm63xx/dts/bcm63169-comtrend-vg-8050.dts
target/linux/bcm63xx/image/bcm63xx_nand.mk

index 93a1cb8fa16e284a920f769aa0fc40ff9156e31e..01158a37911059e9c3d47a51a6378884bc8778f3 100644 (file)
        pinctrl-names = "default";
        pinctrl-0 = <&pinctrl_hsspi_cs5>;
 
-       switch@0 {
+       switch@5 {
                compatible = "brcm,bcm53125";
                reg = <5>;
                spi-max-frequency = <781000>;
                        #address-cells = <1>;
                        #size-cells = <1>;
 
-                       cferom@0 {
+                       partition@0 {
                                label = "cferom";
                                reg = <0x0000000 0x0020000>;
                                read-only;
                        };
 
-                       wfi@20000 {
-                               compatible = "brcm,wfi";
+                       partition@20000 {
+                               compatible = "brcm,wfi-split";
                                label = "wfi";
-                               reg = <0x0020000 0x7ee0000>;
+                               reg = <0x0020000 0x7a80000>;
                        };
                };
        };
index e1aeed66db11d1a06d6b35f99287d96a1ba6c03e..74f23f52af4bd7ac4734b082088b2e0a81b22257 100644 (file)
@@ -59,7 +59,7 @@ define Device/comtrend_vg-8050
   SUBPAGESIZE := 512
   VID_HDR_OFFSET := 2048
   DEVICE_PACKAGES += $(USB2_PACKAGES)
-  CFE_WFI_VERSION := 0x5731
+  CFE_WFI_VERSION := 0x5732
   CFE_WFI_FLASH_TYPE := 3
 endef
 TARGET_DEVICES += comtrend_vg-8050