build: move definition of KBUILD_BUILD_TIMESTAMP to include/kernel.mk
authorAlexander Couzens <lynxis@fe80.eu>
Tue, 13 Jun 2017 11:04:35 +0000 (13:04 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sat, 17 Jun 2017 13:09:57 +0000 (15:09 +0200)
Fixes: 0aed054bec (build: add KERNEL_MAKE and KERNEL_MAKE_FLAGS
variables and move to kernel.mk)

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
include/kernel-defaults.mk
include/kernel.mk

index 8a3e2be0eb6700d3de2bfb72537398ba7eb3d816..f0618633b292c1a7a1f809819a388a799ab61cfd 100644 (file)
@@ -5,12 +5,6 @@
 # See /LICENSE for more information.
 #
 
-ifneq ($(SOURCE_DATE_EPOCH),)
-  ifndef DUMP
-    KBUILD_BUILD_TIMESTAMP:=$(shell perl -e 'print scalar gmtime($(SOURCE_DATE_EPOCH))')
-  endif
-endif
-
 ifdef CONFIG_STRIP_KERNEL_EXPORTS
   KERNEL_MAKEOPTS += \
        EXTRA_LDSFLAGS="-I$(KERNEL_BUILD_DIR) -include symtab.h"
index effece2869d5ad21eba509d2614326a1f3b6b82e..464c94572e9c67d24a6de46f8db1babc6b4d9dc7 100644 (file)
@@ -10,6 +10,12 @@ CHECK:=1
 DUMP:=1
 endif
 
+ifneq ($(SOURCE_DATE_EPOCH),)
+  ifndef DUMP
+    KBUILD_BUILD_TIMESTAMP:=$(shell perl -e 'print scalar gmtime($(SOURCE_DATE_EPOCH))')
+  endif
+endif
+
 ifeq ($(__target_inc),)
   ifndef CHECK
     include $(INCLUDE_DIR)/target.mk