netifd: add basic support for jail network namespaces
authorDaniel Golle <daniel@makrotopia.org>
Tue, 21 Jan 2020 08:18:10 +0000 (10:18 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 21 Jan 2020 08:25:27 +0000 (10:25 +0200)
Prepare netifd for handling procd service jails having their own
network namespace.
Intefaces having the jail attribute will only be brought up inside the
jail's network namespace by procd calling the newly introduced ubus
method 'netns_updown'.
Currently proto 'static' is supported and configuration changes are
not yet being handled (ie. you'll have to restart the jailed service
for changes to take effect).

Example /etc/config/network snippet:
config device 'veth0'
    option type 'veth'
    option name 'vhost0'
    option peer_name 'virt0'

config interface 'virt'
    option type 'bridge'
    list ifname 'vhost0'
    option proto 'static'
    option ipaddr '10.0.0.1'
    option netmask '255.255.255.0'

config interface 'virt0'
    option ifname 'virt0'
    option proto 'static'
    option ipaddr '10.0.0.2'
    option netmask '255.255.255.0'
    option gateway '10.0.0.1'
    option dns '10.0.0.1'
    option jail 'transmission'

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/network/config/netifd/Makefile

index 06c1aeac49e66e5b3ae6ae963ed8b6957adf21e6..8a1bab8c44bdedc4491ef51e71a5fee6601d2d6a 100644 (file)
@@ -5,9 +5,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2020-01-07
-PKG_SOURCE_VERSION:=64f4eb79fe2977320660f8940bc908fa4def807b
-PKG_MIRROR_HASH:=d6c819856030118640e61bbc3abe20fdb6bca2b64b7adc437bcc2f71c8c01b64
+PKG_SOURCE_DATE:=2020-01-18
+PKG_SOURCE_VERSION:=1321c1bd8fe921986c4eb39c3783ddd827b79543
+PKG_MIRROR_HASH:=7e93ba79727e84cc391121be8a190cfa373dee8e2511f75d6f2fcb179928f5fa
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_LICENSE:=GPL-2.0