bcm63xx: nand: sercomm: switch to sercomm-load script
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 2 Jun 2020 11:01:35 +0000 (13:01 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 2 Jun 2020 11:10:00 +0000 (13:10 +0200)
xxd is not a valid dependency and shouldn't be used.
Fixes buildbot failure.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm63xx/image/Makefile

index fdeb100dd96a88aa5f1f9cd2b0a443f140392ce8..eb4b78b06ab9ba303cb0adb55424a03a9bc01fab 100644 (file)
@@ -259,11 +259,12 @@ define Build/cfe-sercomm-part
 endef
 
 define Build/cfe-sercomm-load
-       mv $@ $@.ser
-       echo $(SERCOMM_PID) | xxd -p -r > $@
-       sha256sum $@.ser | awk '{ print $1 }' | xxd -p -r >> $@
-       dd if=$@.ser >> $@
-       rm -f $@.ser
+       $(TOPDIR)/scripts/sercomm-payload.py \
+               --input-file $@ \
+               --output-file $@.new \
+               --pid "$(SERCOMM_PID)"
+
+       mv $@.new $@
 endef
 
 define Build/cfe-sercomm-crypto