ramips: fix serial console for Belkin F5D8235 v1/v2
authorGabor Juhos <juhosg@openwrt.org>
Sun, 2 Dec 2012 14:16:12 +0000 (14:16 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 2 Dec 2012 14:16:12 +0000 (14:16 +0000)
Based on a patch from #12533.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34445

target/linux/ramips/image/Makefile

index 20df6e451be4ef74de5cae4d3630e448b1742fac..585eeac3fe17ab870385434b9011845c8c4009c2 100644 (file)
@@ -247,7 +247,7 @@ mtdlayout_f5d8235=320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(fact
 mtd_f5d8235_kernel_part_size=1572864
 mtd_f5d8235_rootfs_part_size=6356992
 define BuildFirmware/F5D8235
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) $(call  mkmtd/phys,$(mtdlayout_f5d8235)),$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call  mkmtd/phys,$(mtdlayout_f5d8235)),$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
 endef
 
 define BuildFirmware/FONERA20N