build: fixup python SetupHostCommand to use python2
authorEtienne Champetier <champetier.etienne@gmail.com>
Thu, 31 Oct 2019 10:54:59 +0000 (03:54 -0700)
committerPetr Štetiar <ynezz@true.cz>
Sat, 9 Nov 2019 07:26:14 +0000 (08:26 +0100)
Here is a way to break your build env without this patch:
1) have python point to python3, and no python2
2) start the build, SetupHostCommand will create a symlink
./staging_dir/host/bin/python -> /usr/bin/python
3) build fails on scons because it can't find any python2
4) install python2 and restart the build
5) the build fails on wireless-regdb compile because python is python3 instead of python

Signed-off-by: Etienne Champetier <champetier.etienne@gmail.com>
(cherry picked from commit 785d4f3efded4a5094ee8e1ce4535dd0933b956d)

include/prereq-build.mk

index f7da916f648c5c67f73938308fe2df26177204bb..209392b7205c8cb0dc4d90017b305202e55c7a0c 100644 (file)
@@ -142,9 +142,9 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
-       python2.7 -V 2>&1 | grep Python, \
-       python2 -V 2>&1 | grep Python, \
-       python -V 2>&1 | grep Python))
+       python2.7 -V 2>&1 | grep 'Python 2.7', \
+       python2 -V 2>&1 | grep 'Python 2', \
+       python -V 2>&1 | grep 'Python 2'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))