ar71xx/images/senao: fix reproducible issue using tar
authorAlexander Couzens <lynxis@fe80.eu>
Sat, 24 Jun 2017 16:33:52 +0000 (18:33 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Sun, 25 Jun 2017 10:14:26 +0000 (12:14 +0200)
Use deterministic sorting
Use numeric owner/group
Set uid/gid to 0

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
target/linux/ar71xx/image/senao.mk

index 0c56aa49b3b8bb8dddcce27b0b02ddbfabb8a6e3..57e3610e5d5795f6431dd2273f1bae7e2c29023d 100644 (file)
@@ -9,6 +9,7 @@ define Build/senao-factory-image
        $(CP) $(rootfs) $@.senao/openwrt-senao-$(board)-root.squashfs
 
        $(TAR) -c \
+               --numeric-owner --owner=0 --group=0 --sort=name \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
                -C $@.senao . | gzip -9nc > $@