x86: Add Geos profile for Geode subtarget
authorDavid Woodhouse <dwmw2@infradead.org>
Wed, 15 Feb 2017 16:11:12 +0000 (16:11 +0000)
committerJohn Crispin <john@phrozen.org>
Fri, 17 Feb 2017 09:30:38 +0000 (10:30 +0100)
This makes the Geode images actually useful again. The Geos profile
should include the relevant hardware for that board, and the Default
profile adds the via-rhine adapter which seems to have been present in
the net5501 and alix targets killed in commit 9e0759ea265 ("x86: merge
all geode based subtargets into one").

Signed-off-by: David Woodhouse <dwmw2@infradead.org>
target/linux/x86/geode/profiles/000-Generic.mk [new file with mode: 0644]
target/linux/x86/geode/profiles/100-Geos.mk [new file with mode: 0644]
target/linux/x86/geode/target.mk

diff --git a/target/linux/x86/geode/profiles/000-Generic.mk b/target/linux/x86/geode/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..58dc3c6
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+  PACKAGES:= \
+               soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+               hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+               kmod-usb-ohci-pci kmod-hwmon-lm90 \
+               kmod-via-rhine
+endef
+
+define Profile/Generic/Description
+       Generic Profile for all Geode boards.
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/geode/profiles/100-Geos.mk b/target/linux/x86/geode/profiles/100-Geos.mk
new file mode 100644 (file)
index 0000000..94e501e
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Geos
+  NAME:=Geos
+  PACKAGES:= \
+               soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+               hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+               kmod-usb-ohci-pci kmod-hwmon-lm90
+endef
+
+define Profile/Geos/Description
+       Traverse Technologies Geos ADSL router
+endef
+$(eval $(call Profile,Geos))
index 4faa49f6306117851be451c7e44e1ae1954dc49f..9c608e6f9dd951d1e6a2a751c728ffa7952055bf 100644 (file)
@@ -6,6 +6,11 @@ DEFAULT_PACKAGES += \
                        kmod-button-hotplug \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev hwclock wpad-mini
+# Geos
+DEFAULT_PACKAGES += \
+               soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
+               hwclock flashrom tc kmod-pppoa kmod-8139cp kmod-mppe \
+               kmod-usb-ohci-pci kmod-hwmon-lm90
 
 define Target/Description
        Build firmware images for AMD Geode GX/LX based systems (net5501, alix, geos)