ath79: add support for D-Link DIR-505
authorDavid Bauer <mail@david-bauer.net>
Sun, 12 Jan 2020 19:20:43 +0000 (20:20 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 15 Jan 2020 19:38:46 +0000 (20:38 +0100)
This commit adds support for the D-Link DIR-505, previously supported in
ar71xx.

Hardware
--------
SoC:   Atheros AR9330
FLASH: 8M SPI-NOR
RAM:   64M
WIFI:  1T1R 1SS Atheros AR9330
LED:   Power green, Status red
BTN:   WPS, Reset

Installation
------------
Currently, installation is only possible by sysupgrading from an earlier
OpenWrt version, U-Boot TFTP or a modded U-Boot. I do not have the
original bootloader from D-Link on my device anymore, so i cannot test
the factory image.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/dts/ar9330_dlink_dir-505.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/ar9330_dlink_dir-505.dts b/target/linux/ath79/dts/ar9330_dlink_dir-505.dts
new file mode 100644 (file)
index 0000000..6984176
--- /dev/null
@@ -0,0 +1,149 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9330.dtsi"
+
+/ {
+       model = "D-Link DIR-505";
+       compatible = "dlink,dir-505", "qca,ar9330";
+
+       aliases {
+               serial0 = &uart;
+               led-boot = &led_power_green;
+               led-failsafe = &led_status_red;
+               led-running = &led_power_green;
+               led-upgrade = &led_status_red;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               wps {
+                       label = "WPS button";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               reset {
+                       label = "Reset button";
+                       gpios = <&gpio 12 GPIO_ACTIVE_HIGH>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+               pinctrl-names = "default";
+               pinctrl-0 = <&jtag_disable_pins>;
+
+               led_power_green: power {
+                       label = "d-link:green:power";
+                       gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
+               };
+
+               led_status_red: status {
+                       label = "d-link:red:status";
+                       gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+
+       led_enable {
+               gpio-hog;
+               output-low;
+               gpios = <1 GPIO_ACTIVE_LOW>;
+               line-name = "d-link:power:led";
+       };
+};
+
+&usb {
+       dr_mode = "host";
+       status = "okay";
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&eth0 {
+       status = "okay";
+
+       gmac-config {
+               device = <&gmac>;
+               switch-phy-addr-swap = <0>;
+               switch-phy-swap = <0>;
+       };
+};
+
+&eth1 {
+       compatible = "syscon", "simple-mfd";
+       status = "okay";
+};
+
+&spi {
+       num-chipselects = <1>;
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <50000000>;
+               reg = <0>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x10000>;
+                               read-only;
+                       };
+
+                       art: partition@10000 {
+                               label = "art";
+                               reg = <0x10000 0x10000>;
+                               read-only;
+                       };
+
+                       mac: partition@20000 {
+                               label = "mac";
+                               reg = <0x20000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "nvram";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "language";
+                               reg = <0x40000 0x40000>;
+                               read-only;
+                       };
+
+                       partition@80000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x80000 0x780000>;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+       qca,no-eeprom;
+};
index 2bf5751a5cb20283f2134338d036ed137a7d0ad1..a96b504d5ac032065631a2f21fe762b861314ec5 100755 (executable)
@@ -18,6 +18,7 @@ ath79_setup_interfaces()
        devolo,dvl1750c|\
        devolo,dvl1750i|\
        devolo,dvl1750x|\
+       dlink,dir-505|\
        engenius,ecb1750|\
        glinet,gl-ar300m-lite|\
        netgear,ex6400|\
@@ -315,6 +316,9 @@ ath79_setup_macs()
                lan_mac=$(mtd_get_mac_text "caldata" 0xffa0)
                wan_mac=$(mtd_get_mac_text "caldata" 0xffb4)
                ;;
+       dlink,dir-505)
+               lan_mac=$(mtd_get_mac_text "mac" 0x4)
+               ;;
        dlink,dir-825-c1|\
        dlink,dir-835-a1)
                lan_mac=$(mtd_get_mac_text "mac" 0x4)
index 84d840569b4800793fa1c3f9acfaea5b1ae5bcfa..415811625672cb9dcf9c4351cd1fedfc679341b2 100644 (file)
@@ -12,6 +12,7 @@ case "$FIRMWARE" in
        avm,fritz4020)
                caldata_extract_reverse "urlader" 0x1541 0x440
                ;;
+       dlink,dir-505|\
        dlink,dir-825-c1|\
        dlink,dir-835-a1)
                caldata_extract "art" 0x1000 0x440
index abc6f96a802289fe280b31b90328ce79696ff594..800e1c7a7df9a0f10aa2c9f3ffec96c400b133fa 100644 (file)
@@ -373,6 +373,16 @@ define Device/devolo_dvl1750x
 endef
 TARGET_DEVICES += devolo_dvl1750x
 
+define Device/dlink_dir-505
+  SOC := ar9330
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DIR-505
+  IMAGE_SIZE := 7680k
+  DEVICE_PACKAGES := kmod-usb2
+  SUPPORTED_DEVICES += dir-505-a1
+endef
+TARGET_DEVICES += dlink_dir-505
+
 define Device/dlink_dir-825-b1
   SOC := ar7161
   DEVICE_VENDOR := D-Link