kernel: bump 4.14 to 4.14.160
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 25 Dec 2019 16:56:09 +0000 (17:56 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 26 Dec 2019 13:02:24 +0000 (14:02 +0100)
Refreshed all patches.

Compile-tested on: ipq40xx
Runtime-tested on: none

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/kernel-version.mk
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/hack-4.14/721-phy_packets.patch
target/linux/generic/pending-4.14/643-net-bridge-support-hardware-flow-table-offload.patch
target/linux/generic/pending-4.14/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/mediatek/patches-4.14/0048-net-core-add-RPS-balancer.patch
target/linux/mvebu/patches-4.14/408-sfp-move-module-eeprom-ethtool-access-into-netdev-co.patch
target/linux/octeontx/patches-4.14/0001-net-thunderx-add-support-for-rgmii-internal-delay-mo.patch

index c78abab234a45383e1d0b83680a253308fdade93..ee940c6cdbceb4204bd24997d9d0b8f5de2ec739 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .206
-LINUX_VERSION-4.14 = .159
+LINUX_VERSION-4.14 = .160
 
 LINUX_KERNEL_HASH-4.9.206 = 1df27899a9bc4dd874f3830ab9e7b638f0026dffd67a2e230444e5d2805ccad6
-LINUX_KERNEL_HASH-4.14.159 = e8d42d3a1b85d180141e9bc11c4a0e87f8a413c0e989b0f24c1b7c40f8a826f2
+LINUX_KERNEL_HASH-4.14.160 = c60326bad1bcdede514ca8a0bb96843fa7578ef00829cced6218b888b2efa92c
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 484093d55acbd03d6f7e1c4c38b19d5a93f22ba4..b85179982404a97c11858655d8af4a102f2a2f9e 100644 (file)
@@ -65,7 +65,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
         * Before updating sk_refcnt, we must commit prior changes to memory
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -1696,7 +1696,7 @@ u32 tcp_tso_autosize(const struct sock *
+@@ -1697,7 +1697,7 @@ u32 tcp_tso_autosize(const struct sock *
  {
        u32 bytes, segs;
  
@@ -74,7 +74,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
                    sk->sk_gso_max_size - 1 - MAX_TCP_HEADER);
  
        /* Goal is to send at least one packet per ms,
-@@ -2214,7 +2214,7 @@ static bool tcp_small_queue_check(struct
+@@ -2215,7 +2215,7 @@ static bool tcp_small_queue_check(struct
  {
        unsigned int limit;
  
index 9e1c57d92d0181950a802d76cf095f82aeac0a1b..2c59e837afd9cfeda6ffe09b87749e009af82dd8 100644 (file)
@@ -43,7 +43,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1797,6 +1804,10 @@ struct net_device {
+@@ -1802,6 +1809,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
index a070fe16362af4380a8d033a63db814a99c16f73..b54d3cb48fb3ce9ad0167fe6c1ce7c8fb54d4270 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include <linux/uaccess.h>
  #include "br_private.h"
-@@ -340,6 +344,28 @@ static const struct ethtool_ops br_ethto
+@@ -346,6 +350,28 @@ static const struct ethtool_ops br_ethto
        .get_link       = ethtool_op_get_link,
  };
  
@@ -49,7 +49,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static const struct net_device_ops br_netdev_ops = {
        .ndo_open                = br_dev_open,
        .ndo_stop                = br_dev_stop,
-@@ -367,6 +393,9 @@ static const struct net_device_ops br_ne
+@@ -373,6 +399,9 @@ static const struct net_device_ops br_ne
        .ndo_bridge_setlink      = br_setlink,
        .ndo_bridge_dellink      = br_dellink,
        .ndo_features_check      = passthru_features_check,
index f76c39ac183cb92cfab95baf89fb66c24928d585..8919ea34ec75a8826a45beb260cf9e36ce457e17 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1766,6 +1766,8 @@ struct net_device {
+@@ -1771,6 +1771,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
-@@ -6969,6 +7016,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6970,6 +7017,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index e272a25d1f7ef84bdf863d0b1bc35047342b1128..9b94780bcfbc175997beba93b6fb879fd5380481 100644 (file)
@@ -78,7 +78,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
                if (cpu_online(tcpu)) {
                        cpu = tcpu;
                        goto done;
-@@ -8848,6 +8900,9 @@ static int __init net_dev_init(void)
+@@ -8849,6 +8901,9 @@ static int __init net_dev_init(void)
                sd->backlog.weight = weight_p;
        }
  
index 2e4be1bc48cb639522d81de17d022b9018db5c81..19f8f1e6327ce5f03dcb4cd814d297ba3799b9fe 100644 (file)
@@ -129,7 +129,7 @@ Signed-off-by: Russell King <rmk+kernel@armlinux.org.uk>
  /* 802.11 specific */
  struct wireless_dev;
  /* 802.15.4 specific */
-@@ -1935,6 +1936,7 @@ struct net_device {
+@@ -1940,6 +1941,7 @@ struct net_device {
        struct netprio_map __rcu *priomap;
  #endif
        struct phy_device       *phydev;
index efd13da5ec647b7beb7b0da59355693c0566aabc..cf0f96dce361d4c1203928b55f1432406306ece3 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
 +                                                        lmac->lmac_type)))
                        return -ENODEV;
  
-               phy_start_aneg(lmac->phydev);
+               phy_start(lmac->phydev);
 @@ -1287,6 +1289,8 @@ static int bgx_init_of_phy(struct bgx *b
                bgx->lmac[lmac].lmacid = lmac;