procd: support 'requirejail' attribute
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Thu, 30 Jan 2020 18:32:00 +0000 (18:32 +0000)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Tue, 4 Feb 2020 21:51:11 +0000 (21:51 +0000)
Bump procd package to reduce log spam related to missing jail binaries
in a non-jail capable system.

bcb8655 instance: add 'requirejail' attribute

An additional jail attribute 'requirejail' can now be used to indicate
mandatory use of a jailed environment and hence prevent process startup
in the event that the jail subsystem is unavailable.

Procd will now only log errors if jail is unavailable and 1) is a mandatory
requirement or 2) a procd debug level of at least 2 is in use.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/system/procd/Makefile
package/system/procd/files/procd.sh

index 978da29dd0db6816b6a7102c889cd1d143704d92..de2b94b1d9cb86ea322a6f4f709992304c464b88 100644 (file)
@@ -12,9 +12,9 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
-PKG_SOURCE_DATE:=2020-01-24
+PKG_SOURCE_DATE:=2020-02-04
 PKG_SOURCE_VERSION:=00aafc4f439ec3ace834c1a803b899bd1ceba9db
-PKG_MIRROR_HASH:=0d5abe409f8dd5979fa753c2f9999c0434a4b465079fcdd861494814992f1980
+PKG_MIRROR_HASH:=a435449aed225a0394455d627b1ac5ca8bcf27d38238869bad5220a672012688
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0
index b8f9a210f69785b3ad039d918de6a15104fe2db6..e8b1b6ffb7d3bf09725c2451813ca69fb4d74372 100644 (file)
@@ -194,6 +194,7 @@ _procd_add_jail() {
                procfs) json_add_boolean "procfs" "1";;
                sysfs)  json_add_boolean "sysfs" "1";;
                ronly)  json_add_boolean "ronly" "1";;
+               requirejail)    json_add_boolean "requirejail" "1";;
                esac
        done
        json_add_object "mount"