kernel: bump 4.9 to 4.9.202
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 18 Nov 2019 09:22:09 +0000 (10:22 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 19 Nov 2019 14:03:17 +0000 (15:03 +0100)
Refreshed all patches.

Altered patches:
- 902-debloat_proc.patch
- 817-usb-support-layerscape.patch

New symbols:
X86_INTEL_MEMORY_PROTECTION_KEYS
X86_INTEL_TSX_MODE_OFF
X86_INTEL_TSX_MODE_ON
X86_INTEL_TSX_MODE_AUTO

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
13 files changed:
include/kernel-version.mk
target/linux/generic/backport-4.9/040-mm-add-support-for-releasing-multiple-instances-of-a.patch
target/linux/generic/backport-4.9/041-mm-rename-__alloc_page_frag-to-page_frag_alloc-and-_.patch
target/linux/generic/backport-4.9/042-mm-rename-__page_frag-functions-to-__page_frag_cache.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/generic/hack-4.9/207-disable-modorder.patch
target/linux/generic/hack-4.9/660-fq_codel_defaults.patch
target/linux/generic/hack-4.9/721-phy_packets.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/generic/pending-4.9/655-increase_skb_pad.patch
target/linux/layerscape/patches-4.9/202-core-linux-support-layerscape.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch
target/linux/x86/config-4.9

index e602b2dde5aa2eaa42dc59cd137cce2d68ccf380..91ab41b87e8ccece7caeb0a228a95791c3e8e982 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .199
+LINUX_VERSION-4.9 = .202
 LINUX_VERSION-4.14 = .152
 
-LINUX_KERNEL_HASH-4.9.199 = 0f2531f0908e320ee49954e8d84406db659073b202abc514bcc999ceaa3f7ed5
+LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf
 LINUX_KERNEL_HASH-4.14.152 = a9239fd9d341aae07b48a8e7a2afd528fe5cde2617d783454c71e6f3dae2b0aa
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index d4b60d4559b2e9129d2b6f313c46f5b0742b9050..4656bb1db3b4ec966f9d4ed671c019dcd4a591b2 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
 
 --- a/include/linux/gfp.h
 +++ b/include/linux/gfp.h
-@@ -506,6 +506,8 @@ extern void free_hot_cold_page(struct pa
+@@ -529,6 +529,8 @@ extern void free_hot_cold_page(struct pa
  extern void free_hot_cold_page_list(struct list_head *list, bool cold);
  
  struct page_frag_cache;
index facc43004e5ebec05d54e0d55923fc55d66e8fa4..03481d13c8885250b123cdae09e1ba75a9005a80 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
 
 --- a/include/linux/gfp.h
 +++ b/include/linux/gfp.h
-@@ -508,9 +508,9 @@ extern void free_hot_cold_page_list(stru
+@@ -531,9 +531,9 @@ extern void free_hot_cold_page_list(stru
  struct page_frag_cache;
  extern void __page_frag_drain(struct page *page, unsigned int order,
                              unsigned int count);
@@ -52,7 +52,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
  #define free_page(addr) free_pages((addr), 0)
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2476,7 +2476,7 @@ static inline struct sk_buff *netdev_all
+@@ -2477,7 +2477,7 @@ static inline struct sk_buff *netdev_all
  
  static inline void skb_free_frag(void *addr)
  {
index 31b57167b4f9d23e8053343a8f5f12609e5a58fc..cb2bdfc7eeb5ee08c90647af6213c3fd3126012c 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
 
 --- a/include/linux/gfp.h
 +++ b/include/linux/gfp.h
-@@ -506,8 +506,7 @@ extern void free_hot_cold_page(struct pa
+@@ -529,8 +529,7 @@ extern void free_hot_cold_page(struct pa
  extern void free_hot_cold_page_list(struct list_head *list, bool cold);
  
  struct page_frag_cache;
index 3eae2ef0bd29f2ac6ab2857de438d21f1af1df3c..4fd101db27b55ea5f5ca57ed7df6bc5191d4f0f6 100644 (file)
@@ -137,7 +137,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/can/c_can/c_can.c
 +++ b/drivers/net/can/c_can/c_can.c
-@@ -1070,7 +1070,7 @@ static int c_can_poll(struct napi_struct
+@@ -1079,7 +1079,7 @@ static int c_can_poll(struct napi_struct
  
  end:
        if (work_done < quota) {
@@ -668,7 +668,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/ethernet/hisilicon/hip04_eth.c
 +++ b/drivers/net/ethernet/hisilicon/hip04_eth.c
-@@ -559,7 +559,7 @@ refill:
+@@ -561,7 +561,7 @@ refill:
                priv->reg_inten |= RCV_INT;
                writel_relaxed(priv->reg_inten, priv->base + PPE_INTEN);
        }
index f03c62e025353c0c4864bca20077523bf8afb513..62f67ac95d21a6fc87c0cefae0d0a61781ba1b62 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1228,7 +1228,6 @@ all: modules
+@@ -1240,7 +1240,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.fwinst obj=firmware __fw_modbuild
-@@ -1258,7 +1257,6 @@ _modinst_:
+@@ -1270,7 +1269,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index ea461e189dcebcc453882519a890a4d614dbcda0..db77f691e7eeebcd5338ed483de1afd43c705df9 100644 (file)
@@ -24,4 +24,4 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +#endif
        q->drop_batch_size = 64;
        q->quantum = psched_mtu(qdisc_dev(sch));
-       q->perturbation = prandom_u32();
+       get_random_bytes(&q->perturbation, sizeof(q->perturbation));
index d22c8730325f32845cd8f0f1fa1494562cb25650..feb3569f04136a238b04a891a93fcd8136c5b93a 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2339,6 +2339,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2340,6 +2340,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2459,16 +2463,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2460,16 +2464,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
index 8bed139d1b3d04e3d24b1284611162dcea9e34c7..cb13f0ff0255a0a41b3a77b4d2fe7ceb7dd106dc 100644 (file)
@@ -249,10 +249,10 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif
  #ifdef CONFIG_PROC_FS
 -      proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
--      proc_create("pagetypeinfo", S_IRUGO, NULL, &pagetypeinfo_file_ops);
+-      proc_create("pagetypeinfo", 0400, NULL, &pagetypeinfo_file_ops);
 +      if (!IS_ENABLED(CONFIG_PROC_STRIPPED)) {
 +              proc_create("buddyinfo", S_IRUGO, NULL, &fragmentation_file_operations);
-+              proc_create("pagetypeinfo", S_IRUGO, NULL, &pagetypeinfo_file_ops);
++              proc_create("pagetypeinfo", 0400, NULL, &pagetypeinfo_file_ops);
 +              proc_create("zoneinfo", S_IRUGO, NULL, &proc_zoneinfo_file_operations);
 +      }
        proc_create("vmstat", S_IRUGO, NULL, &proc_vmstat_file_operations);
index de96d9a41dc8bed3db194c08c0a1388c268807fc..87f9bb6a95e0abebe79877e4f12043f3958516f9 100644 (file)
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2303,7 +2303,7 @@ static inline int pskb_network_may_pull(
+@@ -2304,7 +2304,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index 95d8aaf6f0f64461a1fc486fa3f89031f343ee04..2ffe1b20f01a00453c05b49487017081a6bc0561 100644 (file)
@@ -384,7 +384,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  void  __kfree_skb(struct sk_buff *skb);
  extern struct kmem_cache *skbuff_head_cache;
  
-@@ -3082,6 +3083,7 @@ static inline void skb_free_datagram_loc
+@@ -3083,6 +3084,7 @@ static inline void skb_free_datagram_loc
  }
  int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
  int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
index 346305869538408e2fd2606985b3eefa64c11796..126829ad3b6e745cb3b0f6344e10ccafe70ec43c 100644 (file)
@@ -206,19 +206,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                if (IS_ENABLED(CONFIG_USB_DWC3_HOST))
                        mode = USB_DR_MODE_HOST;
                else if (IS_ENABLED(CONFIG_USB_DWC3_GADGET))
-@@ -227,8 +246,9 @@ static void dwc3_frame_length_adjustment
-       reg = dwc3_readl(dwc->regs, DWC3_GFLADJ);
-       dft = reg & DWC3_GFLADJ_30MHZ_MASK;
--      if (!dev_WARN_ONCE(dwc->dev, dft == dwc->fladj,
--          "request value same as default, ignoring\n")) {
-+      if (dft == dwc->fladj) {
-+              dev_warn(dwc->dev, "request value same as default, ignoring\n");
-+      } else {
-               reg &= ~DWC3_GFLADJ_30MHZ_MASK;
-               reg |= DWC3_GFLADJ_30MHZ_SDBND_SEL | dwc->fladj;
-               dwc3_writel(dwc->regs, DWC3_GFLADJ, reg);
-@@ -599,6 +619,99 @@ static int dwc3_phy_setup(struct dwc3 *d
+@@ -598,6 +617,99 @@ static int dwc3_phy_setup(struct dwc3 *d
        return 0;
  }
  
@@ -318,7 +306,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  static void dwc3_core_exit(struct dwc3 *dwc)
  {
        dwc3_event_buffers_cleanup(dwc);
-@@ -741,6 +854,8 @@ static int dwc3_core_init(struct dwc3 *d
+@@ -740,6 +852,8 @@ static int dwc3_core_init(struct dwc3 *d
        if (ret)
                goto err1;
  
@@ -327,7 +315,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* Adjust Frame Length */
        dwc3_frame_length_adjustment(dwc);
  
-@@ -939,11 +1054,117 @@ static void dwc3_core_exit_mode(struct d
+@@ -938,11 +1052,117 @@ static void dwc3_core_exit_mode(struct d
        }
  }
  
@@ -445,7 +433,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct resource         *res;
        struct dwc3             *dwc;
        u8                      lpm_nyet_threshold;
-@@ -975,6 +1196,11 @@ static int dwc3_probe(struct platform_de
+@@ -974,6 +1194,11 @@ static int dwc3_probe(struct platform_de
        dwc->xhci_resources[0].flags = res->flags;
        dwc->xhci_resources[0].name = res->name;
  
@@ -457,7 +445,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        res->start += DWC3_GLOBALS_REGS_START;
  
        /*
-@@ -1017,6 +1243,12 @@ static int dwc3_probe(struct platform_de
+@@ -1016,6 +1241,12 @@ static int dwc3_probe(struct platform_de
        dwc->usb3_lpm_capable = device_property_read_bool(dev,
                                "snps,usb3_lpm_capable");
  
@@ -470,7 +458,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        dwc->disable_scramble_quirk = device_property_read_bool(dev,
                                "snps,disable_scramble_quirk");
        dwc->u2exit_lfps_quirk = device_property_read_bool(dev,
-@@ -1061,6 +1293,8 @@ static int dwc3_probe(struct platform_de
+@@ -1060,6 +1291,8 @@ static int dwc3_probe(struct platform_de
        dwc->hird_threshold = hird_threshold
                | (dwc->is_utmi_l1_suspend << 4);
  
@@ -479,7 +467,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        platform_set_drvdata(pdev, dwc);
        dwc3_cache_hwparams(dwc);
  
-@@ -1084,6 +1318,11 @@ static int dwc3_probe(struct platform_de
+@@ -1083,6 +1316,11 @@ static int dwc3_probe(struct platform_de
        if (ret < 0)
                goto err1;
  
@@ -881,15 +869,6 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* DR has been stopped in usb_gadget_unregister_driver() */
        remove_proc_file();
  
-@@ -2570,7 +2580,7 @@ static int fsl_udc_remove(struct platfor
-       dma_pool_destroy(udc_controller->td_pool);
-       free_irq(udc_controller->irq, udc_controller);
-       iounmap(dr_regs);
--      if (pdata->operating_mode == FSL_USB2_DR_DEVICE)
-+      if (res && (pdata->operating_mode == FSL_USB2_DR_DEVICE))
-               release_mem_region(res->start, resource_size(res));
-       /* free udc --wait for the release() finished */
 --- a/drivers/usb/gadget/udc/fsl_usb2_udc.h
 +++ b/drivers/usb/gadget/udc/fsl_usb2_udc.h
 @@ -20,6 +20,10 @@
index af4c5e9e3c91040a4637e2262438103381d574ee..a4cea97f2799c343d88d15f331fb4758b526c914 100644 (file)
@@ -451,7 +451,11 @@ CONFIG_X86_FEATURE_NAMES=y
 CONFIG_X86_GENERIC=y
 # CONFIG_X86_GX_SUSPMOD is not set
 # CONFIG_X86_INTEL_MPX is not set
+# CONFIG_X86_INTEL_MEMORY_PROTECTION_KEYS is not set
 # CONFIG_X86_INTEL_PSTATE is not set
+CONFIG_X86_INTEL_TSX_MODE_OFF=y
+# CONFIG_X86_INTEL_TSX_MODE_ON is not set
+# CONFIG_X86_INTEL_TSX_MODE_AUTO is not set
 CONFIG_X86_INTEL_USERCOPY=y
 CONFIG_X86_INTERNODE_CACHE_SHIFT=6
 CONFIG_X86_IO_APIC=y