mpc85xx: generic: Check kernel size for the TL-WDR4900
authorPawel Dembicki <paweldembicki@gmail.com>
Tue, 29 Jan 2019 18:26:28 +0000 (18:26 +0000)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 13 Apr 2019 16:46:40 +0000 (18:46 +0200)
TP-Link TL-WDR 4900 have u-boot with read-only env.
Boot command read only 0x29F000 data from flash.
Bigger images causes crc error. It can't be changed.

This patch add kernel size checking.

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [utilize KERNEL_SIZE]
target/linux/mpc85xx/image/Makefile

index d2c3ae18618a67c6743579c7224adc02889fa7cc..68c0da84eeb2a6b6613d2c1148170d49141eee21 100644 (file)
@@ -51,6 +51,7 @@ define Device/tl-wdr4900-v1
   TPLINK_HWID := 0x49000001
   TPLINK_HWREV := 1
   TPLINK_FLASHLAYOUT := 16Mppc
+  KERNEL_SIZE := 2684k
   KERNEL_NAME := cuImage.tl-wdr4900-v1
   KERNEL_INITRAMFS :=
   SUPPORTED_DEVICES:=tl-wdr4900-v1 tplink,tl-wdr4900-v1