ramips: rt3833: fix build breakage
authorPetr Štetiar <ynezz@true.cz>
Fri, 15 Nov 2019 06:47:51 +0000 (07:47 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 15 Nov 2019 10:48:03 +0000 (11:48 +0100)
Commit 60f41c6c9ef6 ("ramips: add usb-ledtrig-usbport to DEVICE_PACKAGES
of CY-SWR1100") added stray | during backport which caused build
breakage on the buildbots:

 bash: -c: line 0: syntax error near unexpected token `|'
 bash: -c: line 0: `echo kmod-usb-core kmod-usb-ledtrig-usbport kmod-usb-ohci kmod-usb2 swconfig | | mkhash md5 | head -c 8'

Fixes: 60f41c6c9ef6 ("ramips: add usb-ledtrig-usbport to DEVICE_PACKAGES of CY-SWR1100")
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit a1ff175dbf807925a0bae537935455bd1aa44a98)

target/linux/ramips/image/rt3883.mk

index 0335f0795cac528883d679468c14781371ffadb9..9375591374040fb381b2646f349d16d181a95ca4 100644 (file)
@@ -33,7 +33,7 @@ define Device/cy-swr1100
        seama-seal -m "signature=wrgnd10_samsung_ss815" | \
        check-size $$$$(IMAGE_SIZE)
   DEVICE_TITLE := Samsung CY-SWR1100
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 \
        kmod-usb-ledtrig-usbport swconfig
 endef
 TARGET_DEVICES += cy-swr1100