bcm63xx: ad1018: support Sercomm factory images
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 2 Jun 2020 07:16:49 +0000 (09:16 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 2 Jun 2020 07:16:49 +0000 (09:16 +0200)
This images can be flashed from the official firmware, as opposed to CFE
images, which can only be flashed from CFE and require opening the case.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm63xx/image/bcm63xx_nand.mk

index 57a895f9db4b87ba3f23467c54a0f9e530d8c0b4..7dff893e4fc53d0693e1a6df5a6dd5952182da7a 100644 (file)
@@ -121,7 +121,7 @@ TARGET_DEVICES += netgear_dgnd3700-v2
 
 ### Sercomm ###
 define Device/sercomm_ad1018
-  $(Device/bcm63xx-nand)
+  $(Device/sercomm-nand)
   IMAGE/cfe.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | ad1018-jffs2-cferam | append-ubi | cfe-wfi-tag
   DEVICE_VENDOR := Sercomm
   DEVICE_MODEL := AD1018
@@ -134,5 +134,15 @@ define Device/sercomm_ad1018
   VID_HDR_OFFSET := 2048
   DEVICE_PACKAGES += $(B43_PACKAGES) $(USB2_PACKAGES)
   CFE_WFI_FLASH_TYPE := 3
+  SERCOMM_PID := \
+    30 30 30 30 30 30 30 31 34 31 35 31 35 33 30 30 \
+    30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+    30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+    30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+    30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+    30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 30 \
+    30 30 30 30 33 30 31 33 30 30 30 30 30 30 30 30 \
+    0D 0A 00 00 00 00 00 00 00 00 00 00 00 00 00 00
+  SERCOMM_VERSION := 1001
 endef
 TARGET_DEVICES += sercomm_ad1018