ath79: rename tplink-loader-okli to tplink-safeloader-okli
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 29 Jan 2020 23:06:38 +0000 (00:06 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 2 Feb 2020 12:41:20 +0000 (13:41 +0100)
This renames Device/tplink-loader-okli to Device/tplink-safeloader-okli
since the latter more accurately describes the combination of
tplink-safeloader and loader-okli use there. The old version might
be confused with other uses of the okli loader.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/common-tp-link.mk
target/linux/ath79/image/generic-tp-link.mk

index 0905e605b140ba520c978ee2b2e6b9d4eab875df..a9fccd0fe69f2fa5ef4b76ba4b2b85c39c8c6a7f 100644 (file)
@@ -74,7 +74,7 @@ define Device/tplink-safeloader-uimage
   KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
 endef
 
-define Device/tplink-loader-okli
+define Device/tplink-safeloader-okli
   $(Device/tplink-safeloader)
   LOADER_TYPE := elf
   LOADER_FLASH_OFFS := 0x43000
index 7ac27759ccf82b5fe2638de7ee9b8a5519bb00f9..f1a603dc6d666d880eb5c5a38b7752837d8a40f6 100644 (file)
@@ -213,7 +213,7 @@ endef
 TARGET_DEVICES += tplink_archer-d50-v1
 
 define Device/tplink_cpe210-v1
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := CPE210
@@ -251,7 +251,7 @@ endef
 TARGET_DEVICES += tplink_cpe210-v3
 
 define Device/tplink_cpe220-v2
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := CPE220
@@ -274,7 +274,7 @@ endef
 TARGET_DEVICES += tplink_cpe220-v3
 
 define Device/tplink_cpe510-v1
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := CPE510
@@ -286,7 +286,7 @@ endef
 TARGET_DEVICES += tplink_cpe510-v1
 
 define Device/tplink_cpe510-v2
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := CPE510
@@ -298,7 +298,7 @@ endef
 TARGET_DEVICES += tplink_cpe510-v2
 
 define Device/tplink_cpe510-v3
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := CPE510
@@ -309,7 +309,7 @@ endef
 TARGET_DEVICES += tplink_cpe510-v3
 
 define Device/tplink_cpe610-v1
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := CPE610
@@ -598,7 +598,7 @@ endef
 TARGET_DEVICES += tplink_tl-wr902ac-v1
 
 define Device/tplink_wbs210-v2
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := WBS210
@@ -609,7 +609,7 @@ endef
 TARGET_DEVICES += tplink_wbs210-v2
 
 define Device/tplink_wbs510-v1
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := WBS510
@@ -621,7 +621,7 @@ endef
 TARGET_DEVICES += tplink_wbs510-v1
 
 define Device/tplink_wbs510-v2
-  $(Device/tplink-loader-okli)
+  $(Device/tplink-safeloader-okli)
   SOC := ar9344
   IMAGE_SIZE := 7680k
   DEVICE_MODEL := WBS510