ath79: add support for TP-Link CPE220 v2
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 20 Jul 2019 11:03:43 +0000 (13:03 +0200)
committerDavid Bauer <mail@david-bauer.net>
Wed, 7 Aug 2019 16:04:03 +0000 (18:04 +0200)
This seems to be identical to CPE210 v1 despite having removable
antennas.

Specifications:

    * SoC: Qualcomm Atheros AR9344 (560 MHz)
    * RAM: 64MB
    * Storage: 8 MB
    * Wireless: 2.4GHz N based built into SoC 2x2
    * Ethernet: 2x 100/10 Mbps, integrated into SoC, 24V POE IN

Installation:

Flash factory image through stock firmware WEB UI
or through TFTP:
To get to TFTP recovery just hold reset button while powering on for
around 4-5 seconds and release.
Rename factory image to recovery.bin
Stock TFTP server IP:192.168.0.100
Stock device TFTP address:192.168.0.254

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/board.d/03_gpio_switches
target/linux/ath79/dts/ar9344_tplink_cpe220-v2.dts [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 85d54aa708d27258844235df63745950f9ce13eb..35cb74db287d01ac9f8e2ccedddf30571397867e 100755 (executable)
@@ -159,6 +159,7 @@ tplink,archer-d50-v1)
        ucidef_set_led_switch "wan_link" "WAN Link" "tp-link:white:wan" "switch0" "0x02" "" "link"
        ;;
 tplink,cpe210-v1|\
        ucidef_set_led_switch "wan_link" "WAN Link" "tp-link:white:wan" "switch0" "0x02" "" "link"
        ;;
 tplink,cpe210-v1|\
+tplink,cpe220-v2|\
 tplink,cpe510-v1)
        ucidef_set_led_netdev "lan0" "LAN0" "tp-link:green:lan0" "eth1"
        ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
 tplink,cpe510-v1)
        ucidef_set_led_netdev "lan0" "LAN0" "tp-link:green:lan0" "eth1"
        ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
index e8846f38f3602d0e6930b3a00067709d4e11a519..9c6429984f509721e4d53333d6f3c7c64ab8e626 100755 (executable)
@@ -103,6 +103,7 @@ ath79_setup_interfaces()
        comfast,cf-e110n-v2|\
        comfast,cf-e120a-v3|\
        tplink,cpe210-v1|\
        comfast,cf-e110n-v2|\
        comfast,cf-e120a-v3|\
        tplink,cpe210-v1|\
+       tplink,cpe220-v2|\
        tplink,cpe510-v1|\
        ubnt,nanostation-m|\
        ubnt,routerstation)
        tplink,cpe510-v1|\
        ubnt,nanostation-m|\
        ubnt,routerstation)
index 9dc9feb70c7a553574fdbf9cc2930b901d4e62aa..d84d6cfe85b6e8adff12b9e4d12279c7e1c9ecec 100755 (executable)
@@ -43,6 +43,7 @@ tplink,archer-c25-v1)
        ucidef_add_gpio_switch "led_reset" "LED reset" "19" "1"
        ;;
 tplink,cpe210-v1|\
        ucidef_add_gpio_switch "led_reset" "LED reset" "19" "1"
        ;;
 tplink,cpe210-v1|\
+tplink,cpe220-v2|\
 tplink,cpe510-v1)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "20"
        ;;
 tplink,cpe510-v1)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "20"
        ;;
diff --git a/target/linux/ath79/dts/ar9344_tplink_cpe220-v2.dts b/target/linux/ath79/dts/ar9344_tplink_cpe220-v2.dts
new file mode 100644 (file)
index 0000000..0981b4a
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9344_tplink_cpexxx-v1.dtsi"
+
+/ {
+       compatible = "tplink,cpe220-v2", "qca,ar9344";
+       model = "TP-Link CPE220 v2";
+};
index ffbdfbc14f89c9c14106f30f84b3ec0d7d0e761f..71ea0acddfdc339ac7925dca0d6715fca7da0c16 100644 (file)
@@ -195,6 +195,17 @@ define Device/tplink_cpe210-v3
 endef
 TARGET_DEVICES += tplink_cpe210-v3
 
 endef
 TARGET_DEVICES += tplink_cpe210-v3
 
+define Device/tplink_cpe220-v2
+  $(Device/tplink-loader-okli)
+  ATH_SOC := ar9344
+  IMAGE_SIZE := 7680k
+  DEVICE_MODEL := CPE220
+  DEVICE_VARIANT := v2
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := CPE220V2
+endef
+TARGET_DEVICES += tplink_cpe220-v2
+
 define Device/tplink_cpe510-v1
   $(Device/tplink-loader-okli)
   ATH_SOC := ar9344
 define Device/tplink_cpe510-v1
   $(Device/tplink-loader-okli)
   ATH_SOC := ar9344
index 55f1ab9420881a17a56c66bc2f4e219e124647cb..8dc72c9f43accb53b8346d0ef705ead5268848c1 100644 (file)
@@ -118,7 +118,7 @@ static const uint8_t md5_salt[16] = {
 
 /** Firmware layout table */
 static struct device_info boards[] = {
 
 /** Firmware layout table */
 static struct device_info boards[] = {
-       /** Firmware layout for the CPE210/220 */
+       /** Firmware layout for the CPE210/220 V1 */
        {
                .id     = "CPE210",
                .vendor = "CPE510(TP-LINK|UN|N300-5):1.0\r\n",
        {
                .id     = "CPE210",
                .vendor = "CPE510(TP-LINK|UN|N300-5):1.0\r\n",
@@ -231,6 +231,46 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "support-list",
        },
 
                .last_sysupgrade_partition = "support-list",
        },
 
+       /** Firmware layout for the CPE220 V2 */
+       {
+               .id     = "CPE220V2",
+               .vendor = "CPE510(TP-LINK|UN|N300-5):1.0\r\n",
+               .support_list =
+                       "SupportList:\r\n"
+                       "CPE220(TP-LINK|EU|N300-2|00000000):2.0\r\n"
+                       "CPE220(TP-LINK|EU|N300-2|45550000):2.0\r\n"
+                       "CPE220(TP-LINK|EU|N300-2|55530000):2.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2|00000000):2.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2|45550000):2.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2|55530000):2.0\r\n"
+                       "CPE220(TP-LINK|US|N300-2|55530000):2.0\r\n"
+                       "CPE220(TP-LINK|UN|N300-2):2.0\r\n"
+                       "CPE220(TP-LINK|EU|N300-2):2.0\r\n"
+                       "CPE220(TP-LINK|US|N300-2):2.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x20000},
+                       {"partition-table", 0x20000, 0x02000},
+                       {"default-mac", 0x30000, 0x00020},
+                       {"product-info", 0x31100, 0x00100},
+                       {"signature", 0x32000, 0x00400},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
+                       {"soft-version", 0x7b0000, 0x00100},
+                       {"support-list", 0x7b1000, 0x00400},
+                       {"user-config", 0x7c0000, 0x10000},
+                       {"default-config", 0x7d0000, 0x10000},
+                       {"log", 0x7e0000, 0x10000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "support-list",
+       },
+
        /** Firmware layout for the CPE510/520 */
        {
                .id     = "CPE510",
        /** Firmware layout for the CPE510/520 */
        {
                .id     = "CPE510",