toolchain/gcc: correct the check expr for newer clang
authorYorkie Liu <yorkiefixer@gmail.com>
Tue, 19 Nov 2019 05:41:10 +0000 (13:41 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 23 Dec 2019 00:06:59 +0000 (01:06 +0100)
This fixes gcc build error within clang 11.0, it tweaks the version
string from LLVM to clang.

Signed-off-by: Yorkie Liu <yorkiefixer@gmail.com>
(cherry picked from commit 65a561fd0919eafff2363ae8324db64be2a57f77)

toolchain/gcc/common.mk

index fb60e57c73368e526b92d870fb65d661816c35ac..0b7e5f468e161c8c48b34c47856ce152e440f9f3 100644 (file)
@@ -96,7 +96,7 @@ endif
 
 GCC_CONFIGURE:= \
        SHELL="$(BASH)" \
-       $(if $(shell gcc --version 2>&1 | grep LLVM), \
+       $(if $(shell gcc --version 2>&1 | grep -E "Apple.(LLVM|clang)"), \
                CFLAGS="-O2 -fbracket-depth=512 -pipe" \
                CXXFLAGS="-O2 -fbracket-depth=512 -pipe" \
        ) \