x86: add support to set GRUB menu entry title
authorKjel Delaey <kjel_delaey@hotmail.com>
Tue, 5 Jun 2018 13:47:05 +0000 (15:47 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 30 Jul 2018 13:55:21 +0000 (15:55 +0200)
$ make menuconfig

        Target Images -> Title for the menu entry in GRUB

Signed-off-by: Kjel Delaey <kjel_delaey@hotmail.com>
config/Config-images.in
target/linux/x86/image/Makefile
target/linux/x86/image/grub-iso.cfg
target/linux/x86/image/grub.cfg

index 07ef619e7088dd8161aea90a5661d581f12c8866..76e64641b414c027930c01d25c393c6cd0731d55 100644 (file)
@@ -231,6 +231,14 @@ menu "Target Images"
                help
                  If you don't know, 5 seconds is a reasonable default.
 
+       config GRUB_TITLE
+               string "Title for the menu entry in GRUB"
+               depends on GRUB_IMAGES
+               default "OpenWrt"
+               help
+                 This is the title of the GRUB menu entry.
+                 If unspecified, it defaults to OpenWrt.
+
        config VDI_IMAGES
                bool "Build VirtualBox image files (VDI)"
                depends on TARGET_x86 || TARGET_x86_64
index 8a3cb327e3ccaef77e96e0fceb38a029db2e159e..b537c40f24e6c3c2a2d76fb36095205e8eaaa7cd 100644 (file)
@@ -46,6 +46,7 @@ ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)
 
 GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
+GRUB_TITLE:=$(call qstrip,$(CONFIG_GRUB_TITLE))
 
 ifneq ($(CONFIG_TARGET_x86_xen_domu),)
   GRUB_ROOT = xen/xvda,msdos1
@@ -82,6 +83,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
                -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
                -e 's#@ROOT@#$(GRUB_ROOT)#g' \
+               -e 's#@TITLE@#$(GRUB_TITLE)#g' \
                ./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
        PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" $(SCRIPT_DIR)/gen_image_generic.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -119,6 +121,7 @@ define Image/Build/iso
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
                -e 's#@CMDLINE@#root=/dev/sr0 rootfstype=iso9660 rootwait $(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
                -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+               -e 's#@TITLE@#$(GRUB_TITLE)#g' \
                ./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
        mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
                -o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
index 3d47a95a4b8209b61c8e0f38165b38b929fdaf08..9c59bdf6d49e797ccecc310da08172d84aadf954 100644 (file)
@@ -5,6 +5,6 @@ set default="0"
 set timeout="@TIMEOUT@"
 set root='(cd)'
 
-menuentry "OpenWrt" {
+menuentry "@TITLE@" {
        linux /boot/vmlinuz @CMDLINE@ noinitrd
 }
index 9ec6b2d39c89b7f4a2170456b7ac0c91ff2cee09..dedfa0a6367524e51e24f1128a3b7786ed1cba3a 100644 (file)
@@ -5,9 +5,9 @@ set default="0"
 set timeout="@TIMEOUT@"
 set root='(@ROOT@)'
 
-menuentry "OpenWrt" {
+menuentry "@TITLE@" {
        linux /boot/vmlinuz @CMDLINE@ noinitrd
 }
-menuentry "OpenWrt (failsafe)" {
+menuentry "@TITLE@ (failsafe)" {
        linux /boot/vmlinuz failsafe=true @CMDLINE@ noinitrd
 }