brcm63xx: be more specific about SOC names
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 5 Jan 2020 12:14:43 +0000 (13:14 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 8 Feb 2020 17:48:16 +0000 (18:48 +0100)
This uses the specific SOC names for several devices where the
Chip ID was used incorrectly before.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
13 files changed:
target/linux/brcm63xx/dts/bcm63168-sky-sr102.dts [new file with mode: 0644]
target/linux/brcm63xx/dts/bcm63268-brcm-bcm963269bhr.dts [deleted file]
target/linux/brcm63xx/dts/bcm63268-sky-sr102.dts [deleted file]
target/linux/brcm63xx/dts/bcm63269-brcm-bcm963269bhr.dts [new file with mode: 0644]
target/linux/brcm63xx/dts/bcm6358-huawei-echolife-hg520v.dts [deleted file]
target/linux/brcm63xx/dts/bcm6359-huawei-echolife-hg520v.dts [new file with mode: 0644]
target/linux/brcm63xx/dts/bcm6361-sfr-neufbox-6-sercomm-r0.dts [new file with mode: 0644]
target/linux/brcm63xx/dts/bcm6362-sfr-neufbox-6-sercomm-r0.dts [deleted file]
target/linux/brcm63xx/dts/bcm6368-comtrend-wap-5813n.dts [deleted file]
target/linux/brcm63xx/dts/bcm6368-netgear-evg2000.dts [deleted file]
target/linux/brcm63xx/dts/bcm6369-comtrend-wap-5813n.dts [new file with mode: 0644]
target/linux/brcm63xx/dts/bcm6369-netgear-evg2000.dts [new file with mode: 0644]
target/linux/brcm63xx/image/bcm63xx.mk

diff --git a/target/linux/brcm63xx/dts/bcm63168-sky-sr102.dts b/target/linux/brcm63xx/dts/bcm63168-sky-sr102.dts
new file mode 100644 (file)
index 0000000..e47822a
--- /dev/null
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+#include "bcm63268.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "SKY SR102";
+       compatible = "sky,sr102", "brcm,bcm63168", "brcm,bcm63268";
+
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               wps {
+                       label = "wps";
+                       gpios = <&pinctrl 33 0>;
+                       linux,code = <KEY_WPS_BUTTON>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               lan1_green {
+                       label = "SR102:green:lan1";
+                       gpios = <&pinctrl 1 1>;
+               };
+               power_red {
+                       label = "SR102:red:power";
+                       gpios = <&pinctrl 2 1>;
+               };
+               wifi_red {
+                       label = "SR102:red:wifi";
+                       gpios = <&pinctrl 3 1>;
+               };
+               inet_red {
+                       label = "SR102:red:inet";
+                       gpios = <&pinctrl 4 1>;
+               };
+               inet_white {
+                       label = "SR102:white:inet";
+                       gpios = <&pinctrl 5 0>;
+               };
+               power_white {
+                       label = "SR102:white:power";
+                       gpios = <&pinctrl 6 0>;
+                       default-state = "on";
+               };
+               wifi_white {
+                       label = "SR102:white:wifi";
+                       gpios = <&pinctrl 8 0>;
+               };
+               lan2_red {
+                       label = "SR102:red:lan2";
+                       gpios = <&pinctrl 9 1>;
+               };
+               lan3_red {
+                       label = "SR102:red:lan3";
+                       gpios = <&pinctrl 10 1>;
+               };
+               lan4_red {
+                       label = "SR102:red:lan4";
+                       gpios = <&pinctrl 11 1>;
+               };
+               lan1_red {
+                       label = "SR102:red:lan1";
+                       gpios = <&pinctrl 12 1>;
+               };
+               lan2_green {
+                       label = "SR102:green:lan2";
+                       gpios = <&pinctrl 13 0>;
+               };
+               lan3_green {
+                       label = "SR102:green:lan3";
+                       gpios = <&pinctrl 14 1>;
+               };
+               lan4_green {
+                       label = "SR102:green:lan4";
+                       gpios = <&pinctrl 15 1>;
+               };
+               hd_white {
+                       label = "SR102:white:hd";
+                       gpios = <&pinctrl 18 0>;
+               };
+       };
+};
+
+&hsspi {
+       status = "ok";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <16666667>;
+               spi-tx-bus-width = <2>;
+               spi-rx-bus-width = <2>;
+               reg = <0>;
+
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partitions {
+                       compatible = "brcm,bcm963xx-cfe-nor-partitions";
+               };
+       };
+};
+
+&uart0 {
+       status = "ok";
+};
diff --git a/target/linux/brcm63xx/dts/bcm63268-brcm-bcm963269bhr.dts b/target/linux/brcm63xx/dts/bcm63268-brcm-bcm963269bhr.dts
deleted file mode 100644 (file)
index bb1609e..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-/dts-v1/;
-
-#include "bcm63268.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "Broadcom BCM963269BHR reference board";
-       compatible = "brcm,bcm963269bhr", "brcm,bcm63268";
-
-       chosen {
-               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&pinctrl 32 0>;
-                       linux,code = <KEY_RESTART>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               usb1 {
-                       label = "963269BHR:green:usb1";
-                       gpios = <&pinctrl 9 1>;
-               };
-
-               usb2 {
-                       label = "963269BHR:green:usb2";
-                       gpios = <&pinctrl 10 1>;
-               };
-       };
-};
-
-&hsspi {
-       status = "ok";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               spi-max-frequency = <20000000>;
-               spi-tx-bus-width = <2>;
-               spi-rx-bus-width = <2>;
-               reg = <0>;
-
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partitions {
-                       compatible = "brcm,bcm963xx-cfe-nor-partitions";
-               };
-       };
-};
-
-&uart0 {
-       status = "ok";
-};
diff --git a/target/linux/brcm63xx/dts/bcm63268-sky-sr102.dts b/target/linux/brcm63xx/dts/bcm63268-sky-sr102.dts
deleted file mode 100644 (file)
index 45c1302..0000000
+++ /dev/null
@@ -1,118 +0,0 @@
-/dts-v1/;
-
-#include "bcm63268.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "SKY SR102";
-       compatible = "sky,sr102", "brcm,bcm63268";
-
-       chosen {
-               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               wps {
-                       label = "wps";
-                       gpios = <&pinctrl 33 0>;
-                       linux,code = <KEY_WPS_BUTTON>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               lan1_green {
-                       label = "SR102:green:lan1";
-                       gpios = <&pinctrl 1 1>;
-               };
-               power_red {
-                       label = "SR102:red:power";
-                       gpios = <&pinctrl 2 1>;
-               };
-               wifi_red {
-                       label = "SR102:red:wifi";
-                       gpios = <&pinctrl 3 1>;
-               };
-               inet_red {
-                       label = "SR102:red:inet";
-                       gpios = <&pinctrl 4 1>;
-               };
-               inet_white {
-                       label = "SR102:white:inet";
-                       gpios = <&pinctrl 5 0>;
-               };
-               power_white {
-                       label = "SR102:white:power";
-                       gpios = <&pinctrl 6 0>;
-                       default-state = "on";
-               };
-               wifi_white {
-                       label = "SR102:white:wifi";
-                       gpios = <&pinctrl 8 0>;
-               };
-               lan2_red {
-                       label = "SR102:red:lan2";
-                       gpios = <&pinctrl 9 1>;
-               };
-               lan3_red {
-                       label = "SR102:red:lan3";
-                       gpios = <&pinctrl 10 1>;
-               };
-               lan4_red {
-                       label = "SR102:red:lan4";
-                       gpios = <&pinctrl 11 1>;
-               };
-               lan1_red {
-                       label = "SR102:red:lan1";
-                       gpios = <&pinctrl 12 1>;
-               };
-               lan2_green {
-                       label = "SR102:green:lan2";
-                       gpios = <&pinctrl 13 0>;
-               };
-               lan3_green {
-                       label = "SR102:green:lan3";
-                       gpios = <&pinctrl 14 1>;
-               };
-               lan4_green {
-                       label = "SR102:green:lan4";
-                       gpios = <&pinctrl 15 1>;
-               };
-               hd_white {
-                       label = "SR102:white:hd";
-                       gpios = <&pinctrl 18 0>;
-               };
-       };
-};
-
-&hsspi {
-       status = "ok";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               spi-max-frequency = <16666667>;
-               spi-tx-bus-width = <2>;
-               spi-rx-bus-width = <2>;
-               reg = <0>;
-
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partitions {
-                       compatible = "brcm,bcm963xx-cfe-nor-partitions";
-               };
-       };
-};
-
-&uart0 {
-       status = "ok";
-};
diff --git a/target/linux/brcm63xx/dts/bcm63269-brcm-bcm963269bhr.dts b/target/linux/brcm63xx/dts/bcm63269-brcm-bcm963269bhr.dts
new file mode 100644 (file)
index 0000000..bcd2286
--- /dev/null
@@ -0,0 +1,66 @@
+/dts-v1/;
+
+#include "bcm63268.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "Broadcom BCM963269BHR reference board";
+       compatible = "brcm,bcm963269bhr", "brcm,bcm63269", "brcm,bcm63268";
+
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&pinctrl 32 0>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               usb1 {
+                       label = "963269BHR:green:usb1";
+                       gpios = <&pinctrl 9 1>;
+               };
+
+               usb2 {
+                       label = "963269BHR:green:usb2";
+                       gpios = <&pinctrl 10 1>;
+               };
+       };
+};
+
+&hsspi {
+       status = "ok";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <20000000>;
+               spi-tx-bus-width = <2>;
+               spi-rx-bus-width = <2>;
+               reg = <0>;
+
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partitions {
+                       compatible = "brcm,bcm963xx-cfe-nor-partitions";
+               };
+       };
+};
+
+&uart0 {
+       status = "ok";
+};
diff --git a/target/linux/brcm63xx/dts/bcm6358-huawei-echolife-hg520v.dts b/target/linux/brcm63xx/dts/bcm6358-huawei-echolife-hg520v.dts
deleted file mode 100644 (file)
index 2176ea8..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-/dts-v1/;
-
-#include "bcm6358.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "Huawei EchoLife HG520v";
-       compatible = "huawei,echolife-hg520v", "brcm,bcm6358";
-
-       chosen {
-               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&pinctrl 37 1>;
-                       linux,code = <KEY_RESTART>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               inet_green {
-                       label = "HW520:green:net";
-                       gpios = <&pinctrl 32 1>;
-               };
-       };
-};
-
-&pflash {
-       status = "ok";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               cfe@0 {
-                       label = "CFE";
-                       reg = <0x000000 0x010000>;
-                       read-only;
-               };
-
-               linux@10000 {
-                       label = "linux";
-                       reg = <0x010000 0x3e0000>;
-                       compatible = "brcm,bcm963xx-imagetag";
-               };
-
-               nvram@3f0000 {
-                       label = "nvram";
-                       reg = <0x3f0000 0x010000>;
-               };
-       };
-};
-
-&uart0 {
-       status = "ok";
-};
diff --git a/target/linux/brcm63xx/dts/bcm6359-huawei-echolife-hg520v.dts b/target/linux/brcm63xx/dts/bcm6359-huawei-echolife-hg520v.dts
new file mode 100644 (file)
index 0000000..5809b6d
--- /dev/null
@@ -0,0 +1,69 @@
+/dts-v1/;
+
+#include "bcm6358.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "Huawei EchoLife HG520v";
+       compatible = "huawei,echolife-hg520v", "brcm,bcm6359", "brcm,bcm6358";
+
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&pinctrl 37 1>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               inet_green {
+                       label = "HW520:green:net";
+                       gpios = <&pinctrl 32 1>;
+               };
+       };
+};
+
+&pflash {
+       status = "ok";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               cfe@0 {
+                       label = "CFE";
+                       reg = <0x000000 0x010000>;
+                       read-only;
+               };
+
+               linux@10000 {
+                       label = "linux";
+                       reg = <0x010000 0x3e0000>;
+                       compatible = "brcm,bcm963xx-imagetag";
+               };
+
+               nvram@3f0000 {
+                       label = "nvram";
+                       reg = <0x3f0000 0x010000>;
+               };
+       };
+};
+
+&uart0 {
+       status = "ok";
+};
diff --git a/target/linux/brcm63xx/dts/bcm6361-sfr-neufbox-6-sercomm-r0.dts b/target/linux/brcm63xx/dts/bcm6361-sfr-neufbox-6-sercomm-r0.dts
new file mode 100644 (file)
index 0000000..4498272
--- /dev/null
@@ -0,0 +1,100 @@
+/dts-v1/;
+
+#include "bcm6362.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "SFR Neufbox 6 (Sercomm)";
+       compatible = "sfr,neufbox-6-sercomm-r0", "brcm,bcm6361", "brcm,bcm6362";
+
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               service {
+                       label = "service";
+                       gpios = <&pinctrl 10 1>;
+                       linux,code = <BTN_0>;
+                       debounce-interval = <60>;
+               };
+
+               wlan {
+                       label = "wlan";
+                       gpios = <&pinctrl 12 1>;
+                       linux,code = <KEY_WLAN>;
+                       debounce-interval = <60>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&pinctrl 24 1>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&pinctrl 25 1>;
+                       linux,code = <KEY_WPS_BUTTON>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       switch {
+               compatible = "realtek,rtl8367";
+               gpio-sda = <&pinctrl 18 0>;
+               gpio-sck = <&pinctrl 20 0>;
+
+               realtek,extif0 = <1 5 1 1 1 1 1 1 2>;
+       };
+};
+
+&hsspi {
+       status = "ok";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <20000000>;
+               spi-tx-bus-width = <2>;
+               spi-rx-bus-width = <2>;
+               reg = <0>;
+
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       cfe@0 {
+                               reg = <0x000000 0x010000>;
+                               label = "cfe";
+                               read-only;
+                       };
+
+                       linux@10000 {
+                               reg = <0x010000 0xfe0000>;
+                               label = "linux";
+                               compatible = "brcm,bcm963xx-imagetag";
+                       };
+
+                       nvram@ff0000 {
+                               reg = <0xff0000 0x010000>;
+                               label = "nvram";
+                       };
+               };
+       };
+};
+
+&uart0 {
+       status = "ok";
+};
diff --git a/target/linux/brcm63xx/dts/bcm6362-sfr-neufbox-6-sercomm-r0.dts b/target/linux/brcm63xx/dts/bcm6362-sfr-neufbox-6-sercomm-r0.dts
deleted file mode 100644 (file)
index 031aff0..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-/dts-v1/;
-
-#include "bcm6362.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "SFR Neufbox 6 (Sercomm)";
-       compatible = "sfr,neufbox-6-sercomm-r0", "brcm,bcm6362";
-
-       chosen {
-               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               service {
-                       label = "service";
-                       gpios = <&pinctrl 10 1>;
-                       linux,code = <BTN_0>;
-                       debounce-interval = <60>;
-               };
-
-               wlan {
-                       label = "wlan";
-                       gpios = <&pinctrl 12 1>;
-                       linux,code = <KEY_WLAN>;
-                       debounce-interval = <60>;
-               };
-
-               reset {
-                       label = "reset";
-                       gpios = <&pinctrl 24 1>;
-                       linux,code = <KEY_RESTART>;
-                       debounce-interval = <60>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&pinctrl 25 1>;
-                       linux,code = <KEY_WPS_BUTTON>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       switch {
-               compatible = "realtek,rtl8367";
-               gpio-sda = <&pinctrl 18 0>;
-               gpio-sck = <&pinctrl 20 0>;
-
-               realtek,extif0 = <1 5 1 1 1 1 1 1 2>;
-       };
-};
-
-&hsspi {
-       status = "ok";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               spi-max-frequency = <20000000>;
-               spi-tx-bus-width = <2>;
-               spi-rx-bus-width = <2>;
-               reg = <0>;
-
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       cfe@0 {
-                               reg = <0x000000 0x010000>;
-                               label = "cfe";
-                               read-only;
-                       };
-
-                       linux@10000 {
-                               reg = <0x010000 0xfe0000>;
-                               label = "linux";
-                               compatible = "brcm,bcm963xx-imagetag";
-                       };
-
-                       nvram@ff0000 {
-                               reg = <0xff0000 0x010000>;
-                               label = "nvram";
-                       };
-               };
-       };
-};
-
-&uart0 {
-       status = "ok";
-};
diff --git a/target/linux/brcm63xx/dts/bcm6368-comtrend-wap-5813n.dts b/target/linux/brcm63xx/dts/bcm6368-comtrend-wap-5813n.dts
deleted file mode 100644 (file)
index abf5ea4..0000000
+++ /dev/null
@@ -1,157 +0,0 @@
-/dts-v1/;
-
-#include "bcm6368.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "Comtrend WAP-5813n";
-       compatible = "comtrend,wap-5813n", "brcm,bcm6368";
-
-       chosen {
-               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               wlan {
-                       label = "wlan";
-                       gpios = <&pinctrl 32 1>;
-                       linux,code = <KEY_WLAN>;
-                       debounce-interval = <60>;
-               };
-
-               reset {
-                       label = "reset";
-                       gpios = <&pinctrl 34 1>;
-                       linux,code = <KEY_RESTART>;
-                       debounce-interval = <60>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&pinctrl 35 1>;
-                       linux,code = <KEY_WPS_BUTTON>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               inet_green {
-                       label = "WAP-5813n:green:inet";
-                       gpios = <&pinctrl 5 0>;
-               };
-               power_green {
-                       label = "WAP-5813n:green:power";
-                       gpios = <&pinctrl 22 0>;
-                       default-state = "on";
-               };
-               wps_green {
-                       label = "WAP-5813n:green:wps";
-                       gpios = <&pinctrl 23 1>;
-               };
-               power_red {
-                       label = "WAP-5813n:red:power";
-                       gpios = <&pinctrl 24 0>;
-               };
-               inet_red {
-                       label = "WAP-5813n:red:inet";
-                       gpios = <&pinctrl 31 0>;
-               };
-       };
-};
-
-&pflash {
-       status = "ok";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               cfe@0 {
-                       label = "CFE";
-                       reg = <0x000000 0x010000>;
-                       read-only;
-               };
-
-               linux@10000 {
-                       label = "linux";
-                       reg = <0x010000 0x7e0000>;
-                       compatible = "brcm,bcm963xx-imagetag";
-               };
-
-               nvram@7f0000 {
-                       label = "nvram";
-                       reg = <0x7f0000 0x010000>;
-               };
-       };
-};
-
-&lsspi {
-       switch@0 {
-               compatible = "brcm,bcm53115";
-               reg = <0>;
-               spi-max-frequency = <781000>;
-
-               lede,alias = "eth0";
-
-               ports {
-                       #address-cells = <1>;
-                       #size-cells = <0>;
-
-                       lan@0 {
-                               reg = <0>;
-                               label = "lan4";
-                       };
-
-                       lan@1 {
-                               reg = <1>;
-                               label = "lan3";
-                       };
-
-                       lan@2 {
-                               reg = <2>;
-                               label = "lan2";
-                       };
-
-                       lan@3 {
-                               reg = <3>;
-                               label = "lan1";
-                       };
-
-                       wan@4 {
-                               reg = <4>;
-                               label = "wan";
-                       };
-
-                       cpu@5 {
-                               reg = <5>;
-                               label = "cpu";
-
-                               fixed-link {
-                                       speed = <1000>;
-                                       full-duplex;
-                                       asym-pause;
-                                       pause;
-                               };
-                       };
-               };
-       };
-};
-
-&pinctrl {
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_pci>;
-};
-
-&uart0 {
-       status = "ok";
-};
diff --git a/target/linux/brcm63xx/dts/bcm6368-netgear-evg2000.dts b/target/linux/brcm63xx/dts/bcm6368-netgear-evg2000.dts
deleted file mode 100644 (file)
index 1508291..0000000
+++ /dev/null
@@ -1,124 +0,0 @@
-/dts-v1/;
-
-#include "bcm6368.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "Netgear EVG2000";
-       compatible = "netgear,evg2000", "brcm,bcm6368";
-
-       chosen {
-               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&pinctrl 25 1>;
-                       linux,code = <KEY_RESTART>;
-                       debounce-interval = <60>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&pinctrl 26 1>;
-                       linux,code = <KEY_WPS_BUTTON>;
-                       debounce-interval = <60>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               voip1_green {
-                       label = "EVG2000:green:voip1";
-                       gpios = <&pinctrl 14 1>;
-               };
-               voip2_green {
-                       label = "EVG2000:green:voip2";
-                       gpios = <&pinctrl 2 1>;
-               };
-               inet_red {
-                       label = "EVG2000:red:inet";
-                       gpios = <&pinctrl 4 1>;
-               };
-               inet_green {
-                       label = "EVG2000:green:inet";
-                       gpios = <&pinctrl 5 1>;
-               };
-               usb_green {
-                       label = "EVG2000:green:usb";
-                       gpios = <&pinctrl 15 1>;
-               };
-               power_green {
-                       label = "EVG2000:green:power";
-                       gpios = <&pinctrl 22 1>;
-                       default-state = "on";
-               };
-               power_red {
-                       label = "EVG2000:red:power";
-                       gpios = <&pinctrl 23 1>;
-               };
-               lan_green {
-                       label = "EVG2000:green:lan";
-                       gpios = <&pinctrl 24 1>;
-               };
-               wireless_green {
-                       label = "EVG2000:green:wireless";
-                       gpios = <&pinctrl 26 1>;
-               };
-               wan_green {
-                       label = "EVG2000:green:wan";
-                       gpios = <&pinctrl 27 1>;
-               };
-       };
-};
-
-&pflash {
-       status = "ok";
-
-       partitions {
-               compatible = "fixed-partitions";
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               cfe@0 {
-                       label = "CFE";
-                       reg = <0x00000000 0x00020000>;
-                       read-only;
-               };
-
-               linux@20000 {
-                       label = "linux";
-                       reg = <0x00020000 0x00f40000>;
-                       compatible = "brcm,bcm963xx-imagetag";
-               };
-
-               board_data@f60000 {
-                       label = "board_data";
-                       reg = <0x00f60000 0x00080000>;
-                       read-only;
-               };
-
-               nvram@fe0000 {
-                       label = "nvram";
-                       reg = <0x00fe0000 0x00020000>;
-               };
-       };
-};
-
-&pinctrl {
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_pci>;
-};
-
-&uart0 {
-       status = "ok";
-};
diff --git a/target/linux/brcm63xx/dts/bcm6369-comtrend-wap-5813n.dts b/target/linux/brcm63xx/dts/bcm6369-comtrend-wap-5813n.dts
new file mode 100644 (file)
index 0000000..c6db272
--- /dev/null
@@ -0,0 +1,157 @@
+/dts-v1/;
+
+#include "bcm6368.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "Comtrend WAP-5813n";
+       compatible = "comtrend,wap-5813n", "brcm,bcm6369", "brcm,bcm6368";
+
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               wlan {
+                       label = "wlan";
+                       gpios = <&pinctrl 32 1>;
+                       linux,code = <KEY_WLAN>;
+                       debounce-interval = <60>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&pinctrl 34 1>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&pinctrl 35 1>;
+                       linux,code = <KEY_WPS_BUTTON>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               inet_green {
+                       label = "WAP-5813n:green:inet";
+                       gpios = <&pinctrl 5 0>;
+               };
+               power_green {
+                       label = "WAP-5813n:green:power";
+                       gpios = <&pinctrl 22 0>;
+                       default-state = "on";
+               };
+               wps_green {
+                       label = "WAP-5813n:green:wps";
+                       gpios = <&pinctrl 23 1>;
+               };
+               power_red {
+                       label = "WAP-5813n:red:power";
+                       gpios = <&pinctrl 24 0>;
+               };
+               inet_red {
+                       label = "WAP-5813n:red:inet";
+                       gpios = <&pinctrl 31 0>;
+               };
+       };
+};
+
+&pflash {
+       status = "ok";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               cfe@0 {
+                       label = "CFE";
+                       reg = <0x000000 0x010000>;
+                       read-only;
+               };
+
+               linux@10000 {
+                       label = "linux";
+                       reg = <0x010000 0x7e0000>;
+                       compatible = "brcm,bcm963xx-imagetag";
+               };
+
+               nvram@7f0000 {
+                       label = "nvram";
+                       reg = <0x7f0000 0x010000>;
+               };
+       };
+};
+
+&lsspi {
+       switch@0 {
+               compatible = "brcm,bcm53115";
+               reg = <0>;
+               spi-max-frequency = <781000>;
+
+               lede,alias = "eth0";
+
+               ports {
+                       #address-cells = <1>;
+                       #size-cells = <0>;
+
+                       lan@0 {
+                               reg = <0>;
+                               label = "lan4";
+                       };
+
+                       lan@1 {
+                               reg = <1>;
+                               label = "lan3";
+                       };
+
+                       lan@2 {
+                               reg = <2>;
+                               label = "lan2";
+                       };
+
+                       lan@3 {
+                               reg = <3>;
+                               label = "lan1";
+                       };
+
+                       wan@4 {
+                               reg = <4>;
+                               label = "wan";
+                       };
+
+                       cpu@5 {
+                               reg = <5>;
+                               label = "cpu";
+
+                               fixed-link {
+                                       speed = <1000>;
+                                       full-duplex;
+                                       asym-pause;
+                                       pause;
+                               };
+                       };
+               };
+       };
+};
+
+&pinctrl {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_pci>;
+};
+
+&uart0 {
+       status = "ok";
+};
diff --git a/target/linux/brcm63xx/dts/bcm6369-netgear-evg2000.dts b/target/linux/brcm63xx/dts/bcm6369-netgear-evg2000.dts
new file mode 100644 (file)
index 0000000..93d4792
--- /dev/null
@@ -0,0 +1,124 @@
+/dts-v1/;
+
+#include "bcm6368.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "Netgear EVG2000";
+       compatible = "netgear,evg2000", "brcm,bcm6369", "brcm,bcm6368";
+
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&pinctrl 25 1>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&pinctrl 26 1>;
+                       linux,code = <KEY_WPS_BUTTON>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               voip1_green {
+                       label = "EVG2000:green:voip1";
+                       gpios = <&pinctrl 14 1>;
+               };
+               voip2_green {
+                       label = "EVG2000:green:voip2";
+                       gpios = <&pinctrl 2 1>;
+               };
+               inet_red {
+                       label = "EVG2000:red:inet";
+                       gpios = <&pinctrl 4 1>;
+               };
+               inet_green {
+                       label = "EVG2000:green:inet";
+                       gpios = <&pinctrl 5 1>;
+               };
+               usb_green {
+                       label = "EVG2000:green:usb";
+                       gpios = <&pinctrl 15 1>;
+               };
+               power_green {
+                       label = "EVG2000:green:power";
+                       gpios = <&pinctrl 22 1>;
+                       default-state = "on";
+               };
+               power_red {
+                       label = "EVG2000:red:power";
+                       gpios = <&pinctrl 23 1>;
+               };
+               lan_green {
+                       label = "EVG2000:green:lan";
+                       gpios = <&pinctrl 24 1>;
+               };
+               wireless_green {
+                       label = "EVG2000:green:wireless";
+                       gpios = <&pinctrl 26 1>;
+               };
+               wan_green {
+                       label = "EVG2000:green:wan";
+                       gpios = <&pinctrl 27 1>;
+               };
+       };
+};
+
+&pflash {
+       status = "ok";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               cfe@0 {
+                       label = "CFE";
+                       reg = <0x00000000 0x00020000>;
+                       read-only;
+               };
+
+               linux@20000 {
+                       label = "linux";
+                       reg = <0x00020000 0x00f40000>;
+                       compatible = "brcm,bcm963xx-imagetag";
+               };
+
+               board_data@f60000 {
+                       label = "board_data";
+                       reg = <0x00f60000 0x00080000>;
+                       read-only;
+               };
+
+               nvram@fe0000 {
+                       label = "nvram";
+                       reg = <0x00fe0000 0x00020000>;
+               };
+       };
+};
+
+&pinctrl {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_pci>;
+};
+
+&uart0 {
+       status = "ok";
+};
index bc96b2a24e6365967a251b848913c3eab1ca0e91..265fa0958ae0b501a7643f33b5c9b3e904046b1d 100644 (file)
@@ -304,6 +304,7 @@ define Device/brcm_bcm963269bhr
   IMAGES :=
   CFE_BOARD_ID := 963269BHR
   CFE_CHIP_ID := 63268
+  SOC := bcm63269
   DEVICE_PACKAGES := $(USB2_PACKAGES) kmod-bcm63xx-udc
 endef
 TARGET_DEVICES += brcm_bcm963269bhr
@@ -458,6 +459,7 @@ define Device/comtrend_wap-5813n
   CFE_BOARD_ID := 96369R-1231N
   CFE_CHIP_ID := 6368
   FLASH_MB := 8
+  SOC := bcm6369
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
 TARGET_DEVICES += comtrend_wap-5813n
@@ -643,6 +645,7 @@ define Device/huawei_echolife-hg520v
   CFE_BOARD_ID := HW6358GW_B
   CFE_CHIP_ID := 6358
   CFE_EXTRAS += --rsa-signature "EchoLife_HG520v"
+  SOC := bcm6359
   DEVICE_PACKAGES := $(B43_PACKAGES)
 endef
 TARGET_DEVICES += huawei_echolife-hg520v
@@ -823,6 +826,7 @@ define Device/netgear_evg2000
   BLOCK_SIZE := 0x20000
   NETGEAR_BOARD_ID := U12H154T90_NETGEAR
   NETGEAR_REGION := 1
+  SOC := bcm6369
   DEVICE_PACKAGES := $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
 TARGET_DEVICES += netgear_evg2000
@@ -1002,6 +1006,7 @@ define Device/sfr_neufbox-6-sercomm-r0
   CFE_BOARD_ID := NB6-SER-r0
   CFE_CHIP_ID := 6362
   CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
+  SOC := bcm6361
   DEVICE_PACKAGES := $(USB2_PACKAGES)
 endef
 TARGET_DEVICES += sfr_neufbox-6-sercomm-r0
@@ -1013,6 +1018,7 @@ define Device/sky_sr102
   CFE_BOARD_ID := BSKYB_63168
   CFE_CHIP_ID := 63268
   CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
+  SOC := bcm63168
   DEVICE_PACKAGES := $(USB2_PACKAGES)
 endef
 TARGET_DEVICES += sky_sr102