kernel: bump 4.14 to 4.14.147
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 7 Oct 2019 11:10:45 +0000 (13:10 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 8 Oct 2019 10:46:02 +0000 (12:46 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Compile-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/207-disable-modorder.patch
target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch
target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch
target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch

index a0f6bfa7d0e47d973228d22a9cee1fa178857789..2fbd9de7b74ff0d79419f38b38bfe46367d345c4 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .195
-LINUX_VERSION-4.14 = .146
+LINUX_VERSION-4.14 = .147
 
 LINUX_KERNEL_HASH-4.9.195 = 54be562a2da16eecd612f641146dc099c1aa05c0fc559c971bdfde161c929d68
-LINUX_KERNEL_HASH-4.14.146 = a3c54b887ea3e679382bd4c0536e6a281b071dab2258bd3ee8af75baef2023f5
+LINUX_KERNEL_HASH-4.14.147 = 8fd793688c9d9d4e26fdc175be92b6e638b6a86f4150dd66edecebab0bb85b12
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 16b10e76b8f3e90e565361b60fa7af9856c90780..e67393aa5f7e565fa2e9bc0828fbca707c8b5780 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -1241,7 +1241,6 @@ all: modules
+@@ -1243,7 +1243,6 @@ all: modules
  
  PHONY += modules
  modules: $(vmlinux-dirs) $(if $(KBUILD_BUILTIN),vmlinux) modules.builtin
@@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        @$(kecho) '  Building modules, stage 2.';
        $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
  
-@@ -1270,7 +1269,6 @@ _modinst_:
+@@ -1272,7 +1271,6 @@ _modinst_:
                rm -f $(MODLIB)/build ; \
                ln -s $(CURDIR) $(MODLIB)/build ; \
        fi
index 59651c921a0237c3ffd78b9a11e9771b25334e3a..0a4925d6faf9b8f4eba662e08a5528d86bb16d04 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -2028,7 +2028,7 @@ static int __init pktsched_init(void)
+@@ -2029,7 +2029,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index ed84c6974476f9cf0ee121d091bb00633afeb2c2..932f219cf2963053d67bdf7d31ebb6c19f9b37da 100644 (file)
@@ -7,7 +7,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  1 file changed, 1 insertion(+)
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1833,6 +1833,7 @@ static int __xipram do_write_buffer(stru
+@@ -1839,6 +1839,7 @@ static int __xipram do_write_buffer(stru
  
        /* Write Buffer Load */
        map_write(map, CMD(0x25), cmd_adr);
index 1cadfcdb002d19ab413e19a3754b64873161d5d8..478af4cbc919ed9c9f6ea6dd08f65734ba5e33ee 100644 (file)
@@ -44,7 +44,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd)
-@@ -1792,6 +1796,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1798,6 +1802,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -52,7 +52,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1920,7 +1925,6 @@ static int __xipram do_write_buffer(stru
+@@ -1926,7 +1931,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -60,7 +60,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -1995,6 +1999,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2001,6 +2005,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }