kernel-build: ignore runtime config options during reconfig
authorPetr Štetiar <ynezz@true.cz>
Mon, 18 Nov 2019 13:32:23 +0000 (14:32 +0100)
committerPetr Štetiar <ynezz@true.cz>
Sun, 24 Nov 2019 13:19:43 +0000 (14:19 +0100)
Don't put CC_HAS_ASM_GOTO, IS_GCC, IS_CLANG and GCC_VERSION runtime
config options into the kernel configs during reconfiguration as it
makes no sense, since these options should be set at runtime.

Fixes: FS#2588
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-build.mk

index 684fbd34d3c033faea097ffffc471959408f7ab8..b1d3fc07fd233503901af2cb47f1125f5ee1c29c 100644 (file)
@@ -165,7 +165,9 @@ define BuildKernel
                $(if $(findstring Darwin,$(HOST_OS)),HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses") \
                YACC=$(STAGING_DIR_HOST)/bin/bison \
                $$@
-       $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config > $(LINUX_RECONFIG_TARGET)
+       $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \
+               grep -vE '(CONFIG_CC_(HAS_ASM_GOTO|IS_GCC|IS_CLANG)|GCC_VERSION)=' \
+               > $(LINUX_RECONFIG_TARGET)
 
   install: $(LINUX_DIR)/.image
        +$(MAKE) -C image compile install TARGET_BUILD=