kernel: bump 5.4 to 5.4.38
authorPetr Štetiar <ynezz@true.cz>
Sun, 3 May 2020 12:44:49 +0000 (14:44 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 4 May 2020 19:09:12 +0000 (21:09 +0200)
Refreshed patches.

Run tested: qemu-x86-64, apalis
Build tested: x86/64, ipq40xx, ath79, imx6, sunxi/a53

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0366-sound-soc-only-first-codec-is-master-in-multicodec-s.patch
target/linux/bcm27xx/patches-5.4/950-0373-ARM-dts-bcm283x-Remove-simple-bus-from-fixed-clocks.patch
target/linux/bcm27xx/patches-5.4/950-0375-ARM-dts-bcm283x-Move-pixelvalve-to-bcm2835-common.dt.patch
target/linux/bcm27xx/patches-5.4/950-0420-ARM-dts-Revert-all-changes-to-upstream-dts-files.patch
target/linux/generic/hack-5.4/904-debloat_dma_buf.patch
target/linux/octeontx/patches-5.4/0004-PCI-add-quirk-for-Gateworks-PLX-PEX860x-switch-with-.patch

index 5f364ec2079be84e43fd55dbbb2a6a1ba13a256e..eccea839c32bd4d795028997722338e811026495 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.14 = .176
 LINUX_VERSION-4.19 = .115
-LINUX_VERSION-5.4 = .36
+LINUX_VERSION-5.4 = .38
 
 LINUX_KERNEL_HASH-4.14.176 = bcae0956baaeb55dab5bad0401873fbc5baaa7fbe957ea6d27a5ab241cec5ca2
 LINUX_KERNEL_HASH-4.19.115 = 11b2d97c8ea5ceb40c5e1d0bb87ad5b2b8c84560181bc60c0d28ec3a3e3801c2
-LINUX_KERNEL_HASH-5.4.36 = b9faea98122e8316af8fb428c942e81797b5d28a8fc59a24a4e47959e3765b8d
+LINUX_KERNEL_HASH-5.4.38 = e72b9fa4e3a222d42d64dce9915e5b18f1b75ae722d529a1e560ced2e5d0f30e
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index c4f70ea11f2379bd4ab62edfb46cf3f5f6121020..263f3532f31958b83be0bda033dcc941d958cc53 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Johannes Krude <johannes@krude.de>
 
 --- a/sound/soc/soc-core.c
 +++ b/sound/soc/soc-core.c
-@@ -1646,7 +1646,15 @@ int snd_soc_runtime_set_dai_fmt(struct s
+@@ -1656,7 +1656,15 @@ int snd_soc_runtime_set_dai_fmt(struct s
        int ret;
  
        for_each_rtd_codec_dai(rtd, i, codec_dai) {
index 04b85fd6c5bb35416e9863cd185d7efea4b32a99..db900553439fdeb7355847a380b0162bc5ec9700 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
 
 --- a/arch/arm/boot/dts/bcm283x.dtsi
 +++ b/arch/arm/boot/dts/bcm283x.dtsi
-@@ -634,22 +634,16 @@
+@@ -635,22 +635,16 @@
        };
  
        clocks {
index 5303e937bd7dc29fd32c5e64fac5465d9a0c3bf5..218a846fa3f7a13a2168099f48c4a4a68b65948f 100644 (file)
@@ -97,7 +97,7 @@ Signed-off-by: Stefan Wahren <wahrenst@gmx.net>
                dpi: dpi@7e208000 {
                        compatible = "brcm,bcm2835-dpi";
                        reg = <0x7e208000 0x8c>;
-@@ -607,12 +595,6 @@
+@@ -608,12 +596,6 @@
                        status = "disabled";
                };
  
index df922eaf4b558ad88d5f0d9f3d5e65a0699f37f2..403f534baf2ed6ce8e6a63458746bf640e2c70a6 100644 (file)
@@ -1845,7 +1845,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
                        #address-cells = <1>;
                        #size-cells = <0>;
                        status = "disabled";
-@@ -540,32 +446,6 @@
+@@ -541,32 +447,6 @@
                        status = "disabled";
                };
  
@@ -1878,7 +1878,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
                i2c1: i2c@7e804000 {
                        compatible = "brcm,bcm2835-i2c";
                        reg = <0x7e804000 0x1000>;
-@@ -576,16 +456,6 @@
+@@ -577,16 +457,6 @@
                        status = "disabled";
                };
  
@@ -1895,7 +1895,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
                vec: vec@7e806000 {
                        compatible = "brcm,bcm2835-vec";
                        reg = <0x7e806000 0x1000>;
-@@ -594,20 +464,6 @@
+@@ -595,20 +465,6 @@
                        status = "disabled";
                };
  
@@ -1916,7 +1916,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
                usb: usb@7e980000 {
                        compatible = "brcm,bcm2835-usb";
                        reg = <0x7e980000 0x10000>;
-@@ -619,10 +475,6 @@
+@@ -620,10 +476,6 @@
                        phys = <&usbphy>;
                        phy-names = "usb2-phy";
                };
index 24971487a4bc4b4864f19c43e653fecb6d24f611..1b103d5e0088056e5ef50a83af56446e5436930e 100644 (file)
@@ -54,7 +54,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +MODULE_LICENSE("GPL");
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -2673,6 +2673,7 @@ int wake_up_state(struct task_struct *p,
+@@ -2668,6 +2668,7 @@ int wake_up_state(struct task_struct *p,
  {
        return try_to_wake_up(p, state, 0);
  }
index 58fb20aabb2f796777009dd0d522aa56e0be331c..9784d88546ab9745d00b3f5bcac600d529285538 100644 (file)
@@ -22,10 +22,10 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
  #include <linux/platform_data/x86/apple.h>
  #include <linux/pm_runtime.h>
  #include <linux/switchtec.h>
-@@ -5497,3 +5498,34 @@ out_disable:
- DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_VENDOR_ID_NVIDIA, 0x13b1,
                            PCI_CLASS_DISPLAY_VGA, 8,
-                             quirk_reset_lenovo_thinkpad_p50_nvgpu);
+@@ -5564,3 +5565,34 @@ static void apex_pci_fixup_class(struct
+ }
DECLARE_PCI_FIXUP_CLASS_HEADER(0x1ac1, 0x089a,
+                              PCI_CLASS_NOT_DEFINED, 8, apex_pci_fixup_class);
 +
 +#ifdef CONFIG_PCI_HOST_THUNDER_PEM
 +/*