kernel: bump 4.14 to 4.14.150
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 28 Oct 2019 13:40:43 +0000 (14:40 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 30 Oct 2019 10:21:46 +0000 (11:21 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch

index e1c9422d79a369f7093d2e87a58f8c14647642ac..2b58a8205d37ee290a25185d23ee612d393ad4f0 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .197
-LINUX_VERSION-4.14 = .149
+LINUX_VERSION-4.14 = .150
 
 LINUX_KERNEL_HASH-4.9.197 = 553568b6728d505da70efa8247a66ad158e849c8f5f40d715612ef4e9ed14a0c
-LINUX_KERNEL_HASH-4.14.149 = e69dabd2368440ce1650cda0cf043e1ba3f3343f940a43b68e761739fcb3f296
+LINUX_KERNEL_HASH-4.14.150 = 65c5a4b86b858ba58642f46ae8c983990376d1946e59cc7e054e85b1b7eb57b0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 438ef0821db4316350b0804ab3457356c16d033d..b708fda5ca1ab16f18611ed35b600f66f7c93319 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1954,7 +1954,8 @@ static const struct usb_device_id option
+@@ -1965,7 +1965,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },