scons: move to packages feed
authorPetr Štetiar <ynezz@true.cz>
Sat, 27 Jul 2019 22:33:32 +0000 (00:33 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sun, 15 Sep 2019 20:53:01 +0000 (22:53 +0200)
This patch removes scons host build tool, as commit 7087efd72a8d
("scons: move host build tool to a proper place") in the packages feed
has moved scons into the new home.

There are currently no packages in the master tree which would need
scons, yet scons is build always as part of host tools, just in order to
satisfy host build dependency of few packages in the packages feeds.

Ref: https://github.com/openwrt/packages/pull/9584
Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/scons.mk [deleted file]
tools/Makefile
tools/scons/Makefile [deleted file]
tools/scons/files/pywrap.sh [deleted file]
tools/scons/patches/001-platform_env.patch [deleted file]

diff --git a/include/scons.mk b/include/scons.mk
deleted file mode 100644 (file)
index 2b76710..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-export PLATFORM=posix
-
-SCONS_VARS = \
-       CC="$(TARGET_CC_NOCACHE)" \
-       CXX="$(TARGET_CXX_NOCACHE)" \
-       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
-       CXXFLAGS="$(TARGET_CXXFLAGS) $(EXTRA_CXXFLAGS)" \
-       CPPFLAGS="$(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
-       LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
-       DESTDIR="$(PKG_INSTALL_DIR)"
-
-define Build/Configure/Default
-       (cd $(PKG_BUILD_DIR); \
-               $(SCONS_VARS) \
-               scons \
-                       prefix=/usr \
-                       $(SCONS_OPTIONS) \
-               install \
-       )
-endef
-
-define Build/Compile
-endef
index d7207ba89dd91df558eaf970961fdef225aa1f37..a161154b806b10a20c9ac220e85595918c3a32f1 100644 (file)
@@ -25,7 +25,7 @@ tools-$(BUILD_TOOLCHAIN) += gmp mpfr mpc libelf expat
 tools-y += m4 libtool autoconf automake flex bison pkg-config mklibs zlib
 tools-y += sstrip make-ext4fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-image quilt padjffs2
-tools-y += mm-macros missing-macros cmake scons bc findutils gengetopt patchelf
+tools-y += mm-macros missing-macros cmake bc findutils gengetopt patchelf
 tools-y += mtools dosfstools libressl
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
diff --git a/tools/scons/Makefile b/tools/scons/Makefile
deleted file mode 100644 (file)
index a9f2507..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-#
-# Copyright (C) 2011-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=scons
-PKG_VERSION:=3.1.1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/scons \
-               http://fossies.org/linux/misc/
-PKG_HASH:=4cea417fdd7499a36f407923d03b4b7000b0f9e8fd7b31b316b9ce7eba9143a5
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Configure
-endef
-
-define Host/Compile
-endef
-
-define Host/Install
-       ./files/pywrap.sh $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
-       rm -f $(STAGING_DIR_HOST)/bin/scons*.py
-       for bin in $(STAGING_DIR_HOST)/bin/scons*; do \
-               mv "$$$$bin" "$$$$bin.py";                \
-               cp ./files/pywrap.sh "$$$$bin";           \
-       done
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/scons/files/pywrap.sh b/tools/scons/files/pywrap.sh
deleted file mode 100755 (executable)
index 53910e9..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/usr/bin/env bash
-
-case "${0##*/}" in
-       pywrap.sh) arg1="";;
-       *) arg1="$0.py" ;;
-esac
-
-for bin in python python3; do
-    case "$($bin -V 2>&1)" in
-        "Python 3"*) exec $bin $arg1 "$@" ;;
-    esac
-done
-
-echo "Unable to find a Python 3.x interpreter for executing ${arg1:+$arg1 }$@ !" >&2
-exit 1
diff --git a/tools/scons/patches/001-platform_env.patch b/tools/scons/patches/001-platform_env.patch
deleted file mode 100644 (file)
index 2be3147..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/engine/SCons/Platform/__init__.py
-+++ b/engine/SCons/Platform/__init__.py
-@@ -65,6 +65,8 @@ def platform_default():
-     care about the machine architecture.
-     """
-     osname = os.name
-+    if 'PLATFORM' in os.environ:
-+        return os.environ['PLATFORM']
-     if osname == 'java':
-         osname = os._osType
-     if osname == 'posix':