ath79: add support for the TP-LINK WBS510 V2
authorAndrew Cameron <apcameron@softhome.net>
Thu, 7 Nov 2019 02:12:55 +0000 (20:12 -0600)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 22 Nov 2019 10:41:24 +0000 (11:41 +0100)
This adds support for a popular low-cost 5GHz N based AP

Specifications:
 - SoC: Atheros AR9344
 - RAM: 64MB
 - Storage: 8 MB SPI NOR
 - Wireless: 5GHz 300 Mbps, 2x RP-SMA connector, 27 dBm TX power
 - Ethernet: 1x 10/100 Mbps with 24V POE IN, 1x 10/100 Mbps

Installation:
Flash factory image through stock firmware WEB UI
or through TFTP
To get to TFTP recovery just hold reset button while powering on for
around 4-5 seconds and release.
Rename factory image to recovery.bin
Stock TFTP server IP:192.168.0.100
Stock device TFTP adress:192.168.0.254

Signed-off-by: Andrew Cameron <apcameron@softhome.net>
target/linux/ath79/dts/ar9344_tplink_wbs510-v2.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

diff --git a/target/linux/ath79/dts/ar9344_tplink_wbs510-v2.dts b/target/linux/ath79/dts/ar9344_tplink_wbs510-v2.dts
new file mode 100644 (file)
index 0000000..5c55d78
--- /dev/null
@@ -0,0 +1,13 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9344_tplink_cpexxx-v1.dtsi"
+
+/ {
+       compatible = "tplink,wbs510-v2", "qca,ar9344";
+       model = "TP-Link WBS510 v2";
+};
+
+&led_link4 {
+       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+};
index d54e770240359a45d5fe2a9d172bd4bc0d7875b8..5bb1d92a609e87c2808dcf381caed87f15494f47 100755 (executable)
@@ -175,7 +175,8 @@ tplink,cpe210-v1|\
 tplink,cpe220-v2|\
 tplink,cpe220-v3|\
 tplink,cpe510-v1|\
-tplink,wbs210-v2)
+tplink,wbs210-v2|\
+tplink,wbs510-v2)
        ucidef_set_led_netdev "lan0" "LAN0" "tp-link:green:lan0" "eth1"
        ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
        ucidef_set_rssimon "wlan0" "200000" "1"
index 07f3c4e83c51ecd40e5cf0529270a0ee41bbeb29..dcc0b8be23dfc1f82325a61a0aa7c599e1a3aa49 100755 (executable)
@@ -92,6 +92,7 @@ ath79_setup_interfaces()
        tplink,cpe220-v3|\
        tplink,cpe510-v1|\
        tplink,wbs210-v2|\
+       tplink,wbs510-v2|\
        ubnt,nanostation-m|\
        ubnt,routerstation)
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
index 9bce6cc51bf680c7a987ede27b782529b21d0441..844b212152c83db9f998e81349527513999d2028 100755 (executable)
@@ -46,7 +46,8 @@ tplink,cpe210-v1|\
 tplink,cpe220-v2|\
 tplink,cpe220-v3|\
 tplink,cpe510-v1|\
-tplink,wbs210-v2)
+tplink,wbs210-v2|\
+tplink,wbs510-v2)
        ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "20"
        ;;
 ubnt,nanostation-ac)
index 114c20d3d5b54649c8cb89006f16192460838339..6efed954e436b344b6815818b8d7042bb017552b 100644 (file)
@@ -548,3 +548,14 @@ define Device/tplink_wbs210-v2
   TPLINK_BOARD_ID := WBS210V2
 endef
 TARGET_DEVICES += tplink_wbs210-v2
+
+define Device/tplink_wbs510-v2
+  $(Device/tplink-loader-okli)
+  ATH_SOC := ar9344
+  IMAGE_SIZE := 7680k
+  DEVICE_MODEL := WBS510
+  DEVICE_VARIANT := v2
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := WBS510V2
+endef
+TARGET_DEVICES += tplink_wbs510-v2
index 3ec1fb6ce7604c9157b8e7815cddb2b33db64093..89955725d07cc88fccb5a3529a6d3e7292bdf2ba 100644 (file)
@@ -570,6 +570,39 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "support-list",
        },
 
+       {
+               .id     = "WBS510V2",
+               .vendor = "CPE510(TP-LINK|UN|N300-5):1.0\r\n",
+               .support_list =
+                       "SupportList:\r\n"
+                       "WBS510(TP-LINK|UN|N300-5|00000000):2.0\r\n"
+                       "WBS510(TP-LINK|US|N300-5|55530000):2.0\r\n"
+                       "WBS510(TP-LINK|EU|N300-5|45550000):2.0\r\n"
+                       "WBS510(TP-LINK|CA|N300-5|43410000):2.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x20000},
+                       {"partition-table", 0x20000, 0x02000},
+                       {"default-mac", 0x30000, 0x00020},
+                       {"product-info", 0x31100, 0x00100},
+                       {"signature", 0x32000, 0x00400},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
+                       {"soft-version", 0x7b0000, 0x00100},
+                       {"support-list", 0x7b1000, 0x00400},
+                       {"user-config", 0x7c0000, 0x10000},
+                       {"default-config", 0x7d0000, 0x10000},
+                       {"log", 0x7e0000, 0x10000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "support-list",
+       },
+
        /** Firmware layout for the C2600 */
        {
                .id = "C2600",