ramips: mt7621: add support for Netgear R6800
authorPawel Dembicki <paweldembicki@gmail.com>
Wed, 11 Dec 2019 20:54:24 +0000 (21:54 +0100)
committerDavid Bauer <mail@david-bauer.net>
Wed, 4 Mar 2020 22:02:46 +0000 (23:02 +0100)
This patch adds support for the Netgear R6800, aka Netgear AC1900 and
R6800-100PES.

Specification:
- SoC: MediaTek MT7621AT (880 MHz)
- Flash: 128 MiB NAND
- RAM: 256 MiB
- Wireless: MediaTek MT7615EN b/g/n , MediaTek MT7615EN an+ac
- LAN speed: 10/100/1000
- LAN ports: 4
- WAN speed: 10/100/1000
- WAN ports: 1
- USB 2.0
- USB 3.0
- Serial baud rate of Bootloader and factory firmware: 57600

Known issues:
- Device has 3 wifi LEDs: Wifi 5Ghz, Wifi 2.4Ghz and Wifi on/off.
  Wifi on/off is not used.

Installation:
- apply factory image via stock web-gui.

Back to stock:
- nmrpflash can be used to recover to the stock Netgear firmware.

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
target/linux/ramips/dts/mt7621_netgear_r6800.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_netgear_sercomm_bzv.dtsi [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
target/linux/ramips/mt7621/config-4.14

diff --git a/target/linux/ramips/dts/mt7621_netgear_r6800.dts b/target/linux/ramips/dts/mt7621_netgear_r6800.dts
new file mode 100644 (file)
index 0000000..fed7bbb
--- /dev/null
@@ -0,0 +1,124 @@
+// SPDX-License-Identifier: GPL-2.0
+/dts-v1/;
+
+#include "mt7621_netgear_sercomm_bzv.dtsi"
+
+/ {
+       compatible = "netgear,r6800", "mediatek,mt7621-soc";
+       model = "Netgear R6800";
+
+       aliases {
+               led-boot = &led_power_white;
+               led-failsafe = &led_power_orange;
+               led-running = &led_power_white;
+               led-upgrade = &led_power_orange;
+               label-mac-device = &ethernet;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power_orange: power_orange {
+                       gpios = <&gpio_expander 0 GPIO_ACTIVE_LOW>;
+                       label = "r6800:orange:power";
+               };
+
+               led_power_white: power_white {
+                       gpios = <&gpio_expander 1 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:power";
+               };
+
+               wan_orange {
+                       gpios = <&gpio_expander 2 GPIO_ACTIVE_LOW>;
+                       label = "r6800:orange:wan";
+               };
+
+               wan_white {
+                       gpios = <&gpio_expander 3 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:wan";
+               };
+
+               wlan2g {
+                       gpios = <&gpio_expander 4 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:wlan2g";
+                       linux,default-trigger = "phy0radio";
+               };
+
+               wlan5g {
+                       gpios = <&gpio_expander 5 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:wlan5g";
+                       linux,default-trigger = "phy1radio";
+               };
+
+               usb2 {
+                       gpios = <&gpio_expander 6 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:usb2";
+                       linux,default-trigger = "usbport";
+                       trigger-sources = <&ehci_port2>;
+               };
+
+               usb3 {
+                       gpios = <&gpio_expander 7 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:usb3";
+                       linux,default-trigger = "usbport";
+                       trigger-sources = <&xhci_ehci_port1>;
+               };
+
+               lan1_orange {
+                       gpios = <&gpio_expander 8 GPIO_ACTIVE_LOW>;
+                       label = "r6800:orange:lan1";
+               };
+
+               lan1_white {
+                       gpios = <&gpio_expander 9 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:lan1";
+               };
+
+               lan2_orange {
+                       gpios = <&gpio_expander 10 GPIO_ACTIVE_LOW>;
+                       label = "r6800:orange:lan2";
+               };
+
+               lan2_white {
+                       gpios = <&gpio_expander 11 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:lan2";
+               };
+
+               lan3_orange {
+                       gpios = <&gpio_expander 12 GPIO_ACTIVE_LOW>;
+                       label = "r6800:orange:lan3";
+               };
+
+               lan3_white {
+                       gpios = <&gpio_expander 13 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:lan3";
+               };
+
+               lan4_orange {
+                       gpios = <&gpio_expander 14 GPIO_ACTIVE_LOW>;
+                       label = "r6800:orange:lan4";
+               };
+
+               lan4_white {
+                       gpios = <&gpio_expander 15 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:lan4";
+               };
+
+               wps {
+                       gpios = <&gpio0 17 GPIO_ACTIVE_HIGH>;
+                       label = "r6800:white:wps";
+               };
+
+               wlan {
+                       gpios = <&gpio0 5 GPIO_ACTIVE_LOW>;
+                       label = "r6800:white:wlan";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               ralink,group = "uart3", "uart2", "jtag", "wdt";
+               ralink,function = "gpio";
+       };
+};
diff --git a/target/linux/ramips/dts/mt7621_netgear_sercomm_bzv.dtsi b/target/linux/ramips/dts/mt7621_netgear_sercomm_bzv.dtsi
new file mode 100644 (file)
index 0000000..6538b69
--- /dev/null
@@ -0,0 +1,125 @@
+// SPDX-License-Identifier: GPL-2.0
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "mediatek,mt7621-soc";
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+
+               rfkill {
+                       label = "rfkill";
+                       gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 12 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0>;
+               ieee80211-freq-limit = <2400000 2500000>;
+       };
+};
+
+&pcie1 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+};
+
+&i2c {
+       status = "okay";
+
+       gpio_expander: i2c0gpio-expander@20{
+               #gpio-cells = <2>;
+               #interrupt-cells = <2>;
+               compatible = "semtech,sx1503q";
+               reg = <0x20>;
+
+               gpio-controller;
+       };
+};
+
+&nand {
+       status = "okay";
+
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x100000>;
+                       read-only;
+               };
+
+               partition@100000 {
+                       label = "SC PART_MAP";
+                       reg = <0x100000 0x100000>;
+                       read-only;
+               };
+
+               partition@200000 {
+                       label = "kernel";
+                       reg = <0x200000 0x400000>;
+               };
+
+               partition@600000 {
+                       label = "ubi";
+                       reg = <0x600000 0x2800000>;
+               };
+
+               partition@2e00000 {
+                       label = "reserved0";
+                       reg = <0x2e00000 0x1800000>;
+                       read-only;
+               };
+
+               factory: partition@4600000 {
+                       label = "factory";
+                       reg = <0x4600000 0x200000>;
+                       read-only;
+               };
+
+               partition@4800000 {
+                       label = "reserved1";
+                       reg = <0x4800000 0x3800000>;
+                       read-only;
+               };
+       };
+};
index 4c27cdbd31ed9b11ebb0355aa0408b29f635c6b1..82fbd87df96f617cc5b44ca9782ff2d62df79725 100644 (file)
@@ -595,6 +595,18 @@ define Device/netgear_r6350
 endef
 TARGET_DEVICES += netgear_r6350
 
+define Device/netgear_r6800
+  $(Device/netgear_sercomm_nand)
+  DEVICE_MODEL := R6800
+  SERCOMM_HWNAME := R6950
+  SERCOMM_HWID := BZV
+  SERCOMM_HWVER := A001
+  SERCOMM_SWVER := 0x0062
+  IMAGE_SIZE := 40960k
+  DEVICE_PACKAGES += kmod-mt7615e
+endef
+TARGET_DEVICES += netgear_r6800
+
 define Device/netgear_r6850
   $(Device/netgear_sercomm_nand)
   DEVICE_MODEL := R6850
index 4eab8f42fe4bea0b3ae1198e0db980333026d134..ac73729d1bd2101ddc12fe1bc62da21b7ae7efea 100755 (executable)
@@ -52,6 +52,13 @@ netgear,r6850|\
 netgear,wndr3700-v5)
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x10"
        ;;
+netgear,r6800)
+       ucidef_set_led_switch "wan" "WAN" "$boardname:white:wan" "switch0" "0x10"
+       ucidef_set_led_switch "lan1" "LAN1" "$boardname:white:lan1" "switch0" "0x08"
+       ucidef_set_led_switch "lan2" "LAN2" "$boardname:white:lan2" "switch0" "0x04"
+       ucidef_set_led_switch "lan3" "LAN3" "$boardname:white:lan3" "switch0" "0x02"
+       ucidef_set_led_switch "lan4" "LAN4" "$boardname:white:lan4" "switch0" "0x01"
+       ;;
 tplink,re350-v1|\
 tplink,re650-v1)
        ucidef_set_led_netdev "wifi2g" "Wifi 2.4G" "$boardname:blue:wifi2G" "wlan0"
index 9b7b56f0ba88754eb91973c33b47621fd8e4bcb7..a84ee808a3e6343b04c960df1b297107ebf3895a 100755 (executable)
@@ -41,6 +41,7 @@ ramips_setup_interfaces()
        netgear,r6220|\
        netgear,r6260|\
        netgear,r6350|\
+       netgear,r6800|\
        netgear,r6850|\
        netgear,wndr3700-v5|\
        netis,wf2881|\
@@ -252,6 +253,7 @@ ramips_setup_macs()
                ;;
        netgear,r6260|\
        netgear,r6350|\
+       netgear,r6800|\
        netgear,r6850)
                wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 0x4)" 2)
                ;;
index 465ea0a90910ac5702211c8e8d3348846e6a872d..f6b5c864318e02e07491dd1746fc8dbfe633f725 100755 (executable)
@@ -48,6 +48,7 @@ platform_do_upgrade() {
        netgear,r6220|\
        netgear,r6260|\
        netgear,r6350|\
+       netgear,r6800|\
        netgear,r6850|\
        netis,wf2881|\
        xiaomi,mir3g|\
index 4112cad7809a0e6df7366a730283cc14c35b6972..2ae6afb97fae973ea3765c6d63a91455e2367b64 100644 (file)
@@ -236,6 +236,7 @@ CONFIG_PHYLIB=y
 CONFIG_PINCTRL=y
 CONFIG_PINCTRL_RT2880=y
 # CONFIG_PINCTRL_SINGLE is not set
+CONFIG_PINCTRL_SX150X=y
 CONFIG_POWER_RESET=y
 CONFIG_POWER_RESET_GPIO=y
 CONFIG_POWER_SUPPLY=y