build: remove leftover dependenices on TARGET_rdc
authorFelix Fietkau <nbd@nbd.name>
Thu, 12 May 2016 15:43:17 +0000 (17:43 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 12 May 2016 15:43:48 +0000 (17:43 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
config/Config-images.in
package/kernel/linux/modules/hwmon.mk

index a60dd5078a0d8d7841e4eb54504aac7662bdf151..958bda4227872648c3f2e19c15623d6b932ca8cb 100644 (file)
@@ -186,7 +186,7 @@ menu "Target Images"
 
        config GRUB_IMAGES
                bool "Build GRUB images (Linux x86 or x86_64 host only)"
-               depends on TARGET_x86_64 || (TARGET_x86 && !TARGET_x86_rdc)
+               depends on TARGET_x86
                depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
                default y
index 93d7a775a975418cee753e94b206b6579b79538d..effae14a207acf11d3986017a048ca232b2e3fd0 100644 (file)
@@ -229,7 +229,7 @@ define KernelPackage/hwmon-w83627hf
   KCONFIG:=CONFIG_SENSORS_W83627HF
   FILES:=$(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,w83627hf)
-  $(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
+  $(call AddDepends/hwmon,@TARGET_x86 +kmod-hwmon-vid)
 endef
 
 define KernelPackage/hwmon-w83627hf/description