procd: actually wire-up netns support
authorDaniel Golle <daniel@makrotopia.org>
Thu, 12 Mar 2020 19:53:36 +0000 (20:53 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 12 Mar 2020 19:55:50 +0000 (20:55 +0100)
When support for network namespaces was added to procd, adding the
corresponding jail flag in procd.sh was ommitted. Add it now.

Fixes: 97a03a4760 ("procd: update to latest git HEAD")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/system/procd/Makefile
package/system/procd/files/procd.sh

index 89e5aa96f97b9285910f2e93d94e6888b0efe319..faf06fc25773de12bba43f6d126fd3d055315c34 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
index e8b1b6ffb7d3bf09725c2451813ca69fb4d74372..70317638444757b3c0b22142710e67db5ccfff7e 100644 (file)
@@ -195,6 +195,7 @@ _procd_add_jail() {
                sysfs)  json_add_boolean "sysfs" "1";;
                ronly)  json_add_boolean "ronly" "1";;
                requirejail)    json_add_boolean "requirejail" "1";;
+               netns)  json_add_boolean "netns" "1";;
                esac
        done
        json_add_object "mount"