kernel: bump 4.19 to 4.19.98
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Jan 2020 10:20:03 +0000 (11:20 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Jan 2020 12:14:33 +0000 (13:14 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
12 files changed:
include/kernel-version.mk
target/linux/ath79/patches-4.19/0038-MIPS-ath79-add-missing-QCA955x-GMAC-registers.patch
target/linux/ath79/patches-4.19/0038-at803x-disable-delays.patch
target/linux/ath79/patches-4.19/425-at803x-allow-sgmii-aneg-override.patch
target/linux/ath79/patches-4.19/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.19/950-0039-Add-dwc_otg-driver.patch
target/linux/brcm2708/patches-4.19/950-0261-lan78xx-Debounce-link-events-to-minimize-poll-storm.patch
target/linux/generic/pending-4.19/640-netfilter-nf_flow_table-add-hardware-offload-support.patch
target/linux/generic/pending-4.19/735-net-phy-at803x-fix-at8033-sgmii-mode.patch
target/linux/ipq40xx/patches-4.19/700-net-add-qualcomm-mdio.patch
target/linux/ipq40xx/patches-4.19/705-net-add-qualcomm-ar40xx-phy.patch
target/linux/mediatek/patches-4.19/0003-switch-add-mt7531.patch

index 71c2ae7c6d69c390f005f0576a71b6f76e78a493..429256f40072e40e2bdf5b605c10ffca815f5fb4 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.14 = .167
-LINUX_VERSION-4.19 = .97
+LINUX_VERSION-4.19 = .98
 
 LINUX_KERNEL_HASH-4.14.167 = 2bb78fc7a902faf4f5dad47fdbc2f4bf3df3cf9b41f408e7260f36656659fe43
-LINUX_KERNEL_HASH-4.19.97 = 8fb2a328e05e545274e721cf84baaf612b9330febc6f581b9ead81eaf41496da
+LINUX_KERNEL_HASH-4.19.98 = 91feb13bc22d60d69596ab1d01dfecbec13ef70f00c89a483e0733af94dd2937
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 111c1553d3ad02155ec3ec020d9934a299e7986c..dc0af2fe9cc67af913dcce848d9422c696adad59 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
 +++ b/arch/mips/include/asm/mach-ath79/ar71xx_regs.h
-@@ -1245,7 +1245,12 @@
+@@ -1249,7 +1249,12 @@
   */
  
  #define QCA955X_GMAC_REG_ETH_CFG      0x00
@@ -29,7 +29,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  
  #define QCA955X_ETH_CFG_RGMII_EN      BIT(0)
  #define QCA955X_ETH_CFG_MII_GE0               BIT(1)
-@@ -1267,9 +1272,58 @@
+@@ -1271,9 +1276,58 @@
  #define QCA955X_ETH_CFG_TXE_DELAY_MASK        0x3
  #define QCA955X_ETH_CFG_TXE_DELAY_SHIFT       20
  
@@ -88,4 +88,3 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  /*
   * QCA956X GMAC Interface
   */
-
index 56325a831e45b7f329a59687b55839d05b6d3215..c7a9b3cc78c1b0d9305675a2b2c9a1bf9830a4bc 100644 (file)
@@ -10,7 +10,7 @@ with kernel 5.1 and higher. It can be safely dropped with kernel 5.1.
 
 --- a/drivers/net/phy/at803x.c
 +++ b/drivers/net/phy/at803x.c
-@@ -295,6 +295,14 @@ static int at803x_config_init(struct phy
+@@ -279,6 +279,14 @@ static int at803x_config_init(struct phy
        if (ret < 0)
                return ret;
  
index b0a1942b7a7e5c7e07976137e1728050156e93e8..43c11386c7e860d3915f9bd265f62e308321088d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/at803x.c
 +++ b/drivers/net/phy/at803x.c
-@@ -484,6 +484,13 @@ static int at803x_aneg_done(struct phy_d
+@@ -391,6 +391,13 @@ static int at803x_aneg_done(struct phy_d
        if (!(phy_read(phydev, AT803X_PSSR) & AT803X_PSSR_MR_AN_COMPLETE)) {
                pr_warn("803x_aneg_done: SGMII link is not ok\n");
                aneg_done = 0;
index 201ad740f183c0a6c76df79ca6f42ea3ad9b0b75..6f36dc683ceeb3a4db76ad0c43dd7b7374b0d5b7 100644 (file)
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3894,14 +3894,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3895,14 +3895,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index 346a575050a34d95d11ba32aed335157a34e351b..79c2aa17f05e9329d1e695ba51745b224f34b5f3 100644 (file)
@@ -917,7 +917,7 @@ Fixes https://github.com/raspberrypi/linux/issues/2408
  }
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -5221,7 +5221,7 @@ static void port_event(struct usb_hub *h
+@@ -5222,7 +5222,7 @@ static void port_event(struct usb_hub *h
                u16 status = 0, unused;
                port_dev->over_current_count++;
  
index b481294674ff621ce2d2cd32d7e1a8c36871b54b..98e97706b0ccccad79d9d0494db2505a40fe1d69 100644 (file)
@@ -28,7 +28,7 @@ See: https://github.com/raspberrypi/linux/issues/2447
  static int lan78xx_read_reg(struct lan78xx_net *dev, u32 index, u32 *data)
  {
        u32 *buf = kmalloc(sizeof(u32), GFP_KERNEL);
-@@ -3822,7 +3827,12 @@ static int lan78xx_probe(struct usb_inte
+@@ -3823,7 +3828,12 @@ static int lan78xx_probe(struct usb_inte
        dev->pipe_intr = usb_rcvintpipe(dev->udev,
                                        dev->ep_intr->desc.bEndpointAddress &
                                        USB_ENDPOINT_NUMBER_MASK);
index d9274012cb6f4943945a9609ac2a993bc4f27bd4..a4996efbc870fa78fc56de8210d76ac4d17798e9 100644 (file)
@@ -506,7 +506,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
 +MODULE_ALIAS("nf-flow-table-hw");
 --- a/net/netfilter/nf_tables_api.c
 +++ b/net/netfilter/nf_tables_api.c
-@@ -5478,6 +5478,13 @@ static int nf_tables_flowtable_parse_hoo
+@@ -5490,6 +5490,13 @@ static int nf_tables_flowtable_parse_hoo
        if (err < 0)
                return err;
  
@@ -520,7 +520,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        ops = kcalloc(n, sizeof(struct nf_hook_ops), GFP_KERNEL);
        if (!ops)
                return -ENOMEM;
-@@ -5609,10 +5616,19 @@ static int nf_tables_newflowtable(struct
+@@ -5621,10 +5628,19 @@ static int nf_tables_newflowtable(struct
        }
  
        flowtable->data.type = type;
@@ -540,7 +540,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        err = nf_tables_flowtable_parse_hook(&ctx, nla[NFTA_FLOWTABLE_HOOK],
                                             flowtable);
        if (err < 0)
-@@ -5738,7 +5754,8 @@ static int nf_tables_fill_flowtable_info
+@@ -5750,7 +5766,8 @@ static int nf_tables_fill_flowtable_info
            nla_put_string(skb, NFTA_FLOWTABLE_NAME, flowtable->name) ||
            nla_put_be32(skb, NFTA_FLOWTABLE_USE, htonl(flowtable->use)) ||
            nla_put_be64(skb, NFTA_FLOWTABLE_HANDLE, cpu_to_be64(flowtable->handle),
index 1f81b37f712ded66ae067540880fed572c2c487d..5c00b8781f0c78eb086e60c5796f86896dd6d68b 100644 (file)
@@ -13,17 +13,17 @@ Signed-off-by: Roman Yeryomin <roman@advem.lv>
 
 --- a/drivers/net/phy/at803x.c
 +++ b/drivers/net/phy/at803x.c
-@@ -46,6 +46,7 @@
+@@ -44,6 +44,7 @@
  #define AT803X_FUNC_DATA                      0x4003
  #define AT803X_REG_CHIP_CONFIG                        0x1f
  #define AT803X_BT_BX_REG_SEL                  0x8000
 +#define AT803X_SGMII_ANEG_EN                  0x1000
  
- #define AT803X_PCS_SMART_EEE_CTRL3                    0x805D
- #define AT803X_SMART_EEE_CTRL3_LPI_TX_DELAY_SEL_MASK  0x3
-@@ -268,6 +269,27 @@ static int at803x_config_init(struct phy
+ #define AT803X_DEBUG_ADDR                     0x1D
+ #define AT803X_DEBUG_DATA                     0x1E
+@@ -252,6 +253,27 @@ static int at803x_probe(struct phy_devic
+ static int at803x_config_init(struct phy_device *phydev)
  {
-       struct at803x_platform_data *pdata;
        int ret;
 +      u32 v;
 +
index e939597b8e1d199e68403ec0d826839743055613..847e2e8701b3816bd08ab6bb60d737042f890f59 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -519,6 +519,13 @@ config XILINX_GMII2RGMII
+@@ -524,6 +524,13 @@ config XILINX_GMII2RGMII
          the Reduced Gigabit Media Independent Interface(RGMII) between
          Ethernet physical media devices and the Gigabit Ethernet controller.
  
index 5feea6d4e02b4fbc5b82adfe96c1703063d2f846..4247ef10c6aaa0c617e7742b547cadf242752ac7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -526,6 +526,13 @@ config MDIO_IPQ40XX
+@@ -531,6 +531,13 @@ config MDIO_IPQ40XX
          This driver supports the MDIO interface found in Qualcomm
          Atheros ipq40xx Soc chip.
  
index 096802a30e737d9cac7de17dcaa6c6ad1d76c4d6..43c8d01da79306a0d1013694a5e065fb13025220 100644 (file)
@@ -11,7 +11,7 @@
  config SFP
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -100,3 +100,5 @@ obj-$(CONFIG_STE10XP)              += ste10Xp.o
+@@ -101,3 +101,5 @@ obj-$(CONFIG_STE10XP)              += ste10Xp.o
  obj-$(CONFIG_TERANETICS_PHY)  += teranetics.o
  obj-$(CONFIG_VITESSE_PHY)     += vitesse.o
  obj-$(CONFIG_XILINX_GMII2RGMII) += xilinx_gmii2rgmii.o