kernel: bump 4.14 to 4.14.152
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 6 Nov 2019 16:21:09 +0000 (17:21 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 12 Nov 2019 09:33:42 +0000 (10:33 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/661-use_fq_codel_by_default.patch

index f74a4015147235ca24ff1b0a850e2effff3a7155..e602b2dde5aa2eaa42dc59cd137cce2d68ccf380 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .199
-LINUX_VERSION-4.14 = .151
+LINUX_VERSION-4.14 = .152
 
 LINUX_KERNEL_HASH-4.9.199 = 0f2531f0908e320ee49954e8d84406db659073b202abc514bcc999ceaa3f7ed5
-LINUX_KERNEL_HASH-4.14.151 = ff519c428ee9bbb513a84db5ec32a7e3705cd8c23a57104b25b944cb79583fae
+LINUX_KERNEL_HASH-4.14.152 = a9239fd9d341aae07b48a8e7a2afd528fe5cde2617d783454c71e6f3dae2b0aa
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 0a4925d6faf9b8f4eba662e08a5528d86bb16d04..cf03b00f8210355fbfde450f552495e42ed806af 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/net/sch_generic.h
 +++ b/include/net/sch_generic.h
-@@ -368,12 +368,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
+@@ -373,12 +373,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
  extern struct Qdisc_ops pfifo_fast_ops;
  extern struct Qdisc_ops mq_qdisc_ops;
  extern struct Qdisc_ops noqueue_qdisc_ops;
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -2029,7 +2029,7 @@ static int __init pktsched_init(void)
+@@ -2031,7 +2031,7 @@ static int __init pktsched_init(void)
                return err;
        }