kernel: bump 4.14 to 4.14.165
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 10:00:59 +0000 (11:00 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 12:41:49 +0000 (13:41 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch

index fdec85dd9e9a1a65a0578dc142ce8e9e4b476676..577946a0870e15eebc7f6b5f38658164d988d4bb 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .164
+LINUX_VERSION-4.14 = .165
 LINUX_VERSION-4.19 = .95
 
 LINUX_VERSION-4.19 = .95
 
-LINUX_KERNEL_HASH-4.14.164 = a2031061f3f1472b7fa929f7d0274dd985c8d03ca847acfec1c47847fb7deb4b
+LINUX_KERNEL_HASH-4.14.165 = b0aeb52386404f4e3546f93cf63c857025fc3117ff1b56e3499aa1eae6e088c7
 LINUX_KERNEL_HASH-4.19.95 = 4aedca32eec13ac5103fc23e141f9221dfe120d1c0651c0a2efe7de2182f4fb0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 LINUX_KERNEL_HASH-4.19.95 = 4aedca32eec13ac5103fc23e141f9221dfe120d1c0651c0a2efe7de2182f4fb0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 59e1cff9658202243f59a05895fa0c1639477d72..f70cfef7624737d83c392e5a0d1cce9ff4c6d2df 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1970,7 +1970,8 @@ static const struct usb_device_id option
+@@ -1975,7 +1975,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },