kernel: hwmon: package mcp3021 module
authorDaniel Golle <daniel@makrotopia.org>
Sun, 2 Feb 2020 15:47:38 +0000 (17:47 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 2 Feb 2020 15:49:20 +0000 (17:49 +0200)
Package kernel module for Linear Technology MCP3021/3221 I2C connected
current and voltage monitor chips.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/linux/modules/hwmon.mk

index e79304b4fe5a35261da85051f63f374e33a7e2b9..31836fbceb260872f874a693182b5a17ff5fbfab 100644 (file)
@@ -257,6 +257,21 @@ endef
 $(eval $(call KernelPackage,hwmon-ltc4151))
 
 
+define KernelPackage/hwmon-mcp3021
+  TITLE:=MCP3021/3221 monitoring support
+  KCONFIG:=CONFIG_SENSORS_MCP3021
+  FILES:=$(LINUX_DIR)/drivers/hwmon/mcp3021.ko
+  AUTOLOAD:=$(call AutoProbe,mcp3021)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-mcp3021/description
+ Kernel module for Linear Technology MCP3021/3221 current and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-mcp3021))
+
+
 define KernelPackage/hwmon-nct6775
   TITLE:=NCT6106D/6775F/6776F/6779D/6791D/6792D/6793D and compatibles monitoring support
   KCONFIG:=CONFIG_SENSORS_NCT6775