sdk: fix host menu config targets using ncurses
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Fri, 17 Apr 2020 16:24:10 +0000 (13:24 -0300)
committerPetr Štetiar <ynezz@true.cz>
Wed, 20 May 2020 15:03:45 +0000 (17:03 +0200)
This applies 965f341aa9 ("build: fix host menu config targets using
ncurses") to the SDK top Makefile.

If there is a pkg-config in the staging dir, it will try to use it
instead of the host system's pkg-config; then it will fail to find the
ncurses package.  Linux's default will be used, which fails in some
cases, such as recent Gentoo systems.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
[fixed From: to match SoB]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/sdk/files/Makefile

index 8df1904cb02b9e0a0d3a6c0fdaa9f7e688673fbf..2f89ce0cf85cd5ca5ff6e09579a1e630684046e1 100644 (file)
@@ -14,6 +14,7 @@ export TOPDIR LC_ALL LANG SDK
 
 world:
 
+DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
 export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)