scripts: JSON merge don't crash if no JSON found
authorPaul Spooren <mail@aparcar.org>
Wed, 8 Apr 2020 20:17:01 +0000 (10:17 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 14 Apr 2020 22:16:55 +0000 (23:16 +0100)
The JSON `WORK_DIR` ($(KDIR)/json_info_files) is only created if the new
image generation methods from `image.mk` are used. However some targets
like `armvirt` do not use it yet, so the folder is never created.

The `json_overview_image_info.py` script used to raise an error if the
given `WORK_DIR` isn't a folder, however it should just notify about
missing JSON files.

This patch removes the Python assert and exists with code 0 even if no
JSON files were found, as this is not necessarily an error but simply
not yet implemented. Using `glob` on an not existing `Path` results in
an empty list, therefore the for loop won't run.

Signed-off-by: Paul Spooren <mail@aparcar.org>
CC: Petr Štetiar <ynezz@true.cz>
scripts/json_overview_image_info.py

index 5ed829249bd1950274cfcca42a0dd4631627cc47..a1418e366d6f963aa5ad8c4458aed996207bfd89 100755 (executable)
@@ -15,8 +15,6 @@ assert getenv("WORK_DIR"), "$WORK_DIR required"
 
 work_dir = Path(getenv("WORK_DIR"))
 
 
 work_dir = Path(getenv("WORK_DIR"))
 
-assert work_dir.is_dir(), "$WORK_DIR not a directory"
-
 output = {}
 
 for json_file in work_dir.glob("*.json"):
 output = {}
 
 for json_file in work_dir.glob("*.json"):