ipq40xx: use ath10k-ct-smallbuffers for 128 MiB devices
authorPaul Fertser <fercerpav@gmail.com>
Tue, 24 Dec 2019 17:49:10 +0000 (20:49 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 26 Dec 2019 14:48:23 +0000 (15:48 +0100)
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
target/linux/ipq40xx/image/Makefile

index fada35a49d976406e62e0b9220e3d502d0967847..1fe563c7a5af0749c6e942d8927f328521e76124 100644 (file)
@@ -128,7 +128,8 @@ define Device/asus_rt-ac58u
 #      string and call it a day.... Yeah, we do the latter!
        UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
        IMAGES := sysupgrade.bin
-       DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
+               kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += asus_rt-ac58u
 
@@ -494,6 +495,7 @@ define Device/zyxel_wre6606
        DEVICE_DTS := qcom-ipq4018-wre6606
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += zyxel_wre6606